[R] Installing R-1.3.1 again

Martin Maechler maechler at stat.math.ethz.ch
Wed Oct 3 09:08:46 CEST 2001

>>>>> "Monnie" == Monnie McGee <monnie at xena.hunter.cuny.edu> writes:

    Monnie> Dear All, I have tried twice more to install R-1.3.1 on my
    Monnie> sparc with no success.  I thank you for the useful suggestions
    Monnie> that were sent, even though they didn't seem to help.

    Monnie> I am sorry that I was a bit cryptic in my last note.  Frankly,
    Monnie> I didn't know what information you needed, so I was waiting for
    Monnie> someone to ask some questions.

    Monnie> I hope the following will answer your questions.  I kept a
    Monnie> careful record of everything that I did and all messages that I
    Monnie> received while installing R.  The main problem, I feel, is that
    Monnie> R.bin is not being made for some reason.  I haven't the
    Monnie> foggiest idea why.

    Monnie> First I unpacked R-1.3.1.tgz in the directory /usr/local.  The
    Monnie> first time I tried the installation, I unpacked the file in my
    Monnie> home directory on my sparc machine.  Here are the commands that
    Monnie> followed and the results from each command:

  >> cd R-1.3.1
  >> su

  >> # ./configure

  >> R is now configured for sparc-sun-solaris2.7  
  >> Source directory:          .  
  >> Installation directory:    /usr/local  
  >> C compiler:                gcc  -g -O2  
  >> C++ compiler:              c++  -g -O2  
  >> FORTRAN compiler:          g77  -g -O2  
  >> X11 support:               yes  
  >> Gnome support:             no  
  >> Tcl/Tk support:            no  
  >> R profiling support:       yes  
  >> R as a shared library:     no

  >> configure: warning: you cannot build info versions of the R manuals

{you should install ``GNU texinfo'' (from any GNU mirror),
 and by the way, also ``GNU readline'' which typically is missing from
 Solaris as well}

  >> # make          
  >> make[3]: ar: Command not found
  >> make[3]: *** [libappl.a] Error 127
  >> make[3]: Leaving directory `/usr/local/R-1.3.1/src/appl'
  >> make[2]: *** [R] Error 2
  >> make[2]: Leaving directory `/usr/local/R-1.3.1/src/appl'
  >> make[1]: *** [R] Error 1
  >> make[1]: Leaving directory `/usr/local/R-1.3.1/src'
  >> make: *** [R] Error 1     

You got an error here; so just forget about everything else.
"make check" does not make sense, if "make" completes with an error !

The error  message ``ar: Command not found''
means that your installation of  gcc/g77 is broken:

 man> NAME
 man>      ar - create, modify, and extract from archives.

Prof Brian Ripley usually recommends to use f77 for Solaris instead of
g77,i.e. for you

	rm config.cache
	make clean
	configure --with-f77

but I'm not sure if this will suffice.  You probably need to first install
the GNU compiler suite (gcc etc) properly.

  >> # make check
  >> make[1]: Entering directory `/usr/local/R-1.3.1/tests'

Martin Maechler <maechler at stat.math.ethz.ch>	http://stat.ethz.ch/~maechler/
Seminar fuer Statistik, ETH-Zentrum  LEO D10	Leonhardstr. 27
ETH (Federal Inst. Technology)	8092 Zurich	SWITZERLAND
phone: x-41-1-632-3408		fax: ...-1228			<><
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list