[R] Installing R-1.3.1 again

Monnie McGee monnie at xena.hunter.cuny.edu
Wed Oct 3 00:23:26 CEST 2001

Dear All,

I have tried twice more to install R-1.3.1 on my sparc with no success.  I
thank you for the useful suggestions that were sent, even though they didn't
seem to help.

I am sorry that I was a bit cryptic in my last note.  Frankly, I didn't know
what information you needed, so I was waiting for someone to ask some

I hope the following will answer your questions.  I kept a careful record of
everything that I did and all messages that I received while installing R.
main problem, I feel, is that R.bin is not being made for some reason.  I
haven't the foggiest idea why.

First I unpacked R-1.3.1.tgz in the directory /usr/local.  The first time I
tried the installation, I unpacked the file in my home directory on my sparc
machine.  Here are the commands that followed and the results from each

cd R-1.3.1
# ./configure
R is now configured for sparc-sun-solaris2.7  
Source directory:          .  
Installation directory:    /usr/local  
C compiler:                gcc  -g -O2  
C++ compiler:              c++  -g -O2  
FORTRAN compiler:          g77  -g -O2  
X11 support:               yes  
Gnome support:             no  
Tcl/Tk support:            no  
R profiling support:       yes  
R as a shared library:     no
configure: warning: you cannot build info versions of the R manuals
# make          
make[3]: ar: Command not found
make[3]: *** [libappl.a] Error 127
make[3]: Leaving directory `/usr/local/R-1.3.1/src/appl'
make[2]: *** [R] Error 2
make[2]: Leaving directory `/usr/local/R-1.3.1/src/appl'
make[1]: *** [R] Error 1
make[1]: Leaving directory `/usr/local/R-1.3.1/src'
make: *** [R] Error 1     
# make check
make[1]: Entering directory `/usr/local/R-1.3.1/tests'
make[2]: Entering directory `/usr/local/R-1.3.1/tests'
make[3]: Entering directory `/usr/local/R-1.3.1/tests/Examples'
make[4]: Entering directory `/usr/local/R-1.3.1/tests/Examples'
make[4]: Leaving directory `/usr/local/R-1.3.1/tests/Examples'
make[4]: Entering directory `/usr/local/R-1.3.1/tests/Examples'
collecting examples for package `base' ...
make[5]: Entering directory `/usr/local/R-1.3.1/src/library' 
>>> Building/Updating help pages for package `base'     
Formats: text example 
(.... example list follows ...)
make[5]: Leaving directory `/usr/local/R-1.3.1/src/library'
make[4]: *** No rule to make target `../../bin/R.bin', needed by
`base-Ex.Rout'.  Stop.
make[4]: Leaving directory `/usr/local/R-1.3.1/tests/Examples'
make[3]: *** [test-Examples] Error 2
make[3]: Leaving directory `/usr/local/R-1.3.1/tests/Examples'
make[2]: *** [test-Examples] Error 2
make[2]: Leaving directory `/usr/local/R-1.3.1/tests'
make[1]: *** [test-all-basics] Error 1
make[1]: Leaving directory `/usr/local/R-1.3.1/tests'
make: *** [check] Error 2#     

Since I saw that the process had not made the R.bin file, I did not go further
with make install.  I had done the make install step in a previous
to no avail.

If for some reason you need all of the messages that were printed on the
during the configure, make, and make check stages, I have those, too.  For the
purposes of this e-mail, I chose not to include them.  

By the way, one of my colleagues completed a successful installation of R on
another machine in the department last night.  This machine also runs Solaris
7.  He was helping me with this installation, but became just as stuck as I

Thank you again for your help,
Monnie McGee

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list