[Rd] readRDS and saveRDS

Jeffrey Ryan jeffrey.ryan at lemnica.com
Tue Oct 18 18:47:56 CEST 2011

As load involves a side-effect, I would think that loadRDS is a bad idea.

That said, read/write is far more consistent across all languages and
internally with R than read/save is.

My (worthless) vote is for writeRDS.


On Tue, Oct 18, 2011 at 11:37 AM, Hadley Wickham <hadley at rice.edu> wrote:
>>> Is there any chance that readRDS and saveRDS might one day become
>>> read.rds and write.rds?  That would make them more consistent with the
>>> other reading and writing functions.
>> Ending names in .foo is a bad idea because of the S3 naming conventions, so
>> I think this is unlikely.  But you can always create an alias yourself...
> It just makes teaching that much harder.  We have the pairs:
> * read.csv and write.csv
> * load and save
> * readRDS and saveRDS
> Even loadRDS/saveRDS or readRDS/writeRDS would be better than the current combo.
> Hadley
> --
> Assistant Professor / Dobelman Family Junior Chair
> Department of Statistics / Rice University
> http://had.co.nz/
> ______________________________________________
> R-devel at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel

Jeffrey Ryan
jeffrey.ryan at lemnica.com


More information about the R-devel mailing list