[Rd] readRDS and saveRDS

Hadley Wickham hadley at rice.edu
Tue Oct 18 18:37:06 CEST 2011

>> Is there any chance that readRDS and saveRDS might one day become
>> read.rds and write.rds?  That would make them more consistent with the
>> other reading and writing functions.
> Ending names in .foo is a bad idea because of the S3 naming conventions, so
> I think this is unlikely.  But you can always create an alias yourself...

It just makes teaching that much harder.  We have the pairs:

* read.csv and write.csv
* load and save
* readRDS and saveRDS

Even loadRDS/saveRDS or readRDS/writeRDS would be better than the current combo.


Assistant Professor / Dobelman Family Junior Chair
Department of Statistics / Rice University

More information about the R-devel mailing list