[Rd] readRDS and saveRDS

Duncan Murdoch murdoch.duncan at gmail.com
Tue Oct 18 18:56:59 CEST 2011

On 18/10/2011 12:37 PM, Hadley Wickham wrote:
> >>  Is there any chance that readRDS and saveRDS might one day become
> >>  read.rds and write.rds?  That would make them more consistent with the
> >>  other reading and writing functions.
> >
> >  Ending names in .foo is a bad idea because of the S3 naming conventions, so
> >  I think this is unlikely.  But you can always create an alias yourself...
> It just makes teaching that much harder.  We have the pairs:
> * read.csv and write.csv
> * load and save
> * readRDS and saveRDS
> Even loadRDS/saveRDS or readRDS/writeRDS would be better than the current combo.

Every problem is an opportunity.  Think of this as an example of why 
it's important to think about the names you give to functions.

Duncan Murdoch

More information about the R-devel mailing list