[BioC] Installing genefilter

Monnie McGee mmcgee at smu.edu
Thu Feb 10 21:07:30 CET 2005

Dear Bioc help,

I would like to use the package genefilter  in order to do some 
nonspecific filtering of a microarray expression set (eset).  When I 
typed "library(genefilter)" into R, I received the following error 

Error in library.dynam(lib, package, package.lib) :
         shared library 'genefilter' not found
In addition: Warning message:
Package  'genefilter' contains no R code in: loadNamespace(package, 
c(which.lib.loc, lib.loc))
Error in library(genefilter) : package/namespace load failed for 

I thought that genefilter should have been downloaded by default when I 
downloaded bioconductor with "getBioC()".  But, I tried to download it 
using "install.packages2".  Here's what I did:

if (interactive()){
z <- repositories

I then received the message:

Warning message:
cannot open: HTTP status was `404 Not Found'
Note: http://www.bioconductor.org/CRANrepository does not seem to have 
a valid repository, skipping
Warning message:
Failed to read replisting at http://www.bioconductor.org/CRANrepository 
in: getReplisting(repURL, repFile, method = method)

But, a few seconds later, the list of repositories appeared.  When it 
did, I typed 1 for "Release 1.5 source repository" and hit return.

Then, I received the following message:

[1] "Attempting to download genefilter from 
[1] "Download complete."
[1] "Installing genefilter"
* Installing *source* package 'genefilter' ...
** libs
gcc -no-cpp-precomp -I/Library/Frameworks/R.framework/Resources/include 
  -I/usr/local/include   -fno-common  -g -O2 -c genedist.c -o genedist.o
gcc -no-cpp-precomp -I/Library/Frameworks/R.framework/Resources/include 
  -I/usr/local/include   -fno-common  -g -O2 -c init.c -o init.o
g77   -fno-common  -g -O2 -c ttest.f -o ttest.o
gcc -bundle -flat_namespace -undefined suppress -L/usr/local/lib -o 
genefilter.so genedist.o init.o ttest.o  -L/usr/local/lib 
-L/usr/local/lib/gcc/powerpc-apple-darwin6.8/3.4.2/../../.. -lfrtbegin 
-lg2c -lSystem -lcc_dynamic -framework R
ld: warning -L: directory name (/usr/local/lib) does not exist
ld: warning -L: directory name (/usr/local/lib) does not exist
ld: warning -L: directory name 
(/usr/local/lib/gcc/powerpc-apple-darwin6.8/3.4.2) does not exist
ld: warning -L: directory name 
(/usr/local/lib/gcc/powerpc-apple-darwin6.8/3.4.2/../../..) does not 
ld: can't locate file for: -lfrtbegin
make: *** [genefilter.so] Error 1
ERROR: compilation failed for package 'genefilter'
** Removing '/private/tmp/RtmppOfGwL/file615be850/genefilter'
** Restoring previous '/private/tmp/RtmppOfGwL/file615be850/genefilter'
 From URL:  
         genefilter version 1.5.0

Warning message:
Installation of package genefilter had non-zero exit status in: 
installPkg(fileName, pkg, pkgVer, type, lib, repEntry, versForce)

The upshot of all of this is that I do not have genefilter installed on 
my machine (a powerbook G4, by the way).

I tried the exact same procedure with the package "limma" and was 
successful.  Genefilter is the only package that gives me this problem 
- and "multtest", but that is because multtest needs genefilter to run.

Please help!
Thank You,
Monnie McGee

More information about the Bioconductor mailing list