[R-SIG-Mac] Corrupt R installation

moleps islon mo|ep@2 @end|ng |rom gm@||@com
Tue Jun 8 22:46:35 CEST 2021

Copied from SO (
and sent here instead at the suggestion of  Dirk Eddelbuettel

I have no idea why, but my R installation (Mac OS X - Big Sur)
automatically updates causing havoc with my libraries each time. My Mac is
under administration from the university and their software center, but
they claim it is not their fault - but I still suspect them for causing all
the trouble.

Anyhow - after that last update to 4.1.0 the packages were again all lost.
I tried a dirty hack just symlinking to the old version and updating (I
know-- very stupid, but I didnt have time for a major update of all the
packages), but after this my R-installation has been totally chaos for the
past week. I´ve reinstalled everything multiple times (brew, llvm, gcc,
CLI, X-code -- you name it) and I´ve finally managed to get data.table
working again with openMP support using the instructions at SO

However I still get the following error message when installing data.table
from source:

dylib (/usr/local/opt/llvm/lib/libunwind.dylib) was built for newer macOS
version (11.0) than being linked (10.16)
Does it matter? Any idea how I can fix it?

	[[alternative HTML version deleted]]

More information about the R-SIG-Mac mailing list