[R-SIG-Mac] Corrupt R installation

Simon Urbanek @|mon@urb@nek @end|ng |rom R-project@org
Wed Jun 9 02:07:28 CEST 2021

You seem to have entirely non-standard setup that you're on your own and I assume you're not using CRAN R since you involve homebrew (which explains the chaos) so presumably you re-compiled R yourself and all packages, but I'd like to point out that if all you are after is OpenMP support then you don't need any of that fragile mess as explained at https://mac.r-project.org/openmp/


> On 9/06/2021, at 8:46 AM, moleps islon <moleps2 using gmail.com> wrote:
> Copied from SO (
> https://stackoverflow.com/questions/67892321/major-r-installation-corruption)
> and sent here instead at the suggestion of  Dirk Eddelbuettel
> <https://stackoverflow.com/users/143305/dirk-eddelbuettel>
> I have no idea why, but my R installation (Mac OS X - Big Sur)
> automatically updates causing havoc with my libraries each time. My Mac is
> under administration from the university and their software center, but
> they claim it is not their fault - but I still suspect them for causing all
> the trouble.
> Anyhow - after that last update to 4.1.0 the packages were again all lost.
> I tried a dirty hack just symlinking to the old version and updating (I
> know-- very stupid, but I didnt have time for a major update of all the
> packages), but after this my R-installation has been totally chaos for the
> past week. I´ve reinstalled everything multiple times (brew, llvm, gcc,
> CLI, X-code -- you name it) and I´ve finally managed to get data.table
> working again with openMP support using the instructions at SO
> <https://stackoverflow.com/questions/65251887/clang-7-error-linker-command-failed-with-exit-code-1-for-macos-big-sur/65334247#65334247>
> (
> https://stackoverflow.com/questions/65251887/clang-7-error-linker-command-failed-with-exit-code-1-for-macos-big-sur/65334247#65334247
> ).
> However I still get the following error message when installing data.table
> from source:
> dylib (/usr/local/opt/llvm/lib/libunwind.dylib) was built for newer macOS
> version (11.0) than being linked (10.16)
> Does it matter? Any idea how I can fix it?
> 	[[alternative HTML version deleted]]
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac using r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list