[R-SIG-Mac] Rstan compilation hangs misterisouly

Goncalo Ferraz g|@pp|e @end|ng |rom m@c@com
Mon Nov 9 02:43:09 CET 2020


Yes, at some point there was a problem with schools.stan, it needed an extra (empty) line added to the end. But that didn’t solve the problem. I tried at least three different tests, with different models, and the same thing happens.

Tried to get rid of .MakeVars and as I remember it didn’t change anything. I wanted to try it again now, but I am not finding a .MakeVars file anywhere on my computer. Where should it be?



> On Nov 8, 2020, at 8:04 PM, Ken Beath <ken using kjbeath.com.au> wrote:
> Guessing here. Possibly schools.stan has a problem, that is what teh first error is suggesting. The remaining is a possible problem with .MakeVars which is no longer needed with R. I would also check that files aren’t being saved with a strange encoding.
> Ken
>> On 9 Nov 2020, at 7:25 am, Roy Mendelssohn - NOAA Federal via R-SIG-Mac <r-sig-mac using r-project.org> wrote:
>> Hi:
>> While it is possible you will get the help you seek here,  I think you would likely to get more help,  and more knowledgeable help, on this more specialized issue,  at the Stan Forum.  https://discourse.mc-stan.org.  I remember seeing in the summaries I get some issues with different combinations of versions of R,  Stan and compilers.
>> HTH,
>> -Roy
>>> On Nov 8, 2020, at 12:16 PM, Goncalo Ferraz via R-SIG-Mac <r-sig-mac using r-project.org> wrote:
>>> Hi, 
>>> I’ve been struggling with an rstan problem for weeks. I installed R stan following instructions in https://github.com/stan-dev/rstan/wiki/RStan-Getting-Started#how-to-use-rstan <https://github.com/stan-dev/rstan/wiki/RStan-Getting-Started#how-to-use-rstan> to the letter, but when I try to compile any model R leaves me hanging indefinitely (I’ve waited up to 30 minutes with ridiculously short models). When I press esc R says:
>>> Warning messages:
>>> 1: In readLines(file, warn = TRUE) :
>>> incomplete final line found on '/Users/gferraz/Documents/MAF/R/schools.stan'
>>> 2: In system(paste(CXX, ARGS), ignore.stdout = TRUE, ignore.stderr = TRUE) :
>>> system call failed: Result too large
>>> 3: In system(paste(CXX, ARGS), ignore.stdout = TRUE, ignore.stderr = TRUE) :
>>> error in running command
>>> And then, R won’t quit. I can only close it by force quitting the software itself and some R process that is set in motion and appears in the Activity Monitor.
>>> I have tried everything that was suggested in the stan forum, including deleting all the contents of /usr/local, removing xcode, R and re-installing everything again.
>>> The only thing that I can think of now is to do a clean install of Mac OS on my machine and really start from scratch.
>>> Anyone has a less radical recommendation?
>>> Thank you,
>>> Gonçalo
>>> 	[[alternative HTML version deleted]]
>>> _______________________________________________
>>> R-SIG-Mac mailing list
>>> R-SIG-Mac using r-project.org
>>> https://stat.ethz.ch/mailman/listinfo/r-sig-mac
>> **********************
>> "The contents of this message do not reflect any position of the U.S. Government or NOAA."
>> **********************
>> Roy Mendelssohn
>> Supervisory Operations Research Analyst
>> Environmental Research Division
>> Southwest Fisheries Science Center
>> ***Note new street address***
>> 110 McAllister Way
>> Santa Cruz, CA 95060
>> Phone: (831)-420-3666
>> Fax: (831) 420-3980
>> e-mail: Roy.Mendelssohn using noaa.gov www: https://www.pfeg.noaa.gov/
>> "Old age and treachery will overcome youth and skill."
>> "From those who have been given much, much will be expected" 
>> "the arc of the moral universe is long, but it bends toward justice" -MLK Jr.
>> _______________________________________________
>> R-SIG-Mac mailing list
>> R-SIG-Mac using r-project.org
>> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list