[R-SIG-Mac] Can't open files in 4.0 or 4.01

Bob Rudis bob @end|ng |rom rud@|@
Sun Jun 7 23:51:19 CEST 2020

Are there any entries in Console.app that might help triage?

Have you tried creating a new user on your Mac and seeing if that account has issues performing the same tasks your user account is having?

Having said that, I just grabbed "Mac OS X GUI rev. 7843 for R 4.0.x" from mac.r-project.org (I never use R.app nor do I keep it installed unless testing something) and am running R 4.0.1 on latest Catalina beta — 10.15.6 Beta (19G36e) — and it crashes every time I try to open a .R file (crashlog https://paste.sr.ht/~hrbrmstr/9899f3a7f3c1724cc952b935c3fc39a47cac88ac)

> On Jun 7, 2020, at 16:22, Carl Witthoft <carl using witthoft.com> wrote:
> Hi,
> 2 weeks ago I installed R 4.0 on my new Catalina machine. Things seemed to be working fine.
> Today I installed R 4.01, and now I can't open any FILE.r - no matter what way I try, i.e. double-click the file, drag/drop, or open from the R GUI menu,  R hangs with the beachball.
> I tried giving R full disk access and other privileges via Security settings; no help.
> So I deleted R 4.01 and reinstalled R 4.0, and dang if I no longer can open files any more!  I've tried all the suggestions in the previous thread in this mailing group; no help.
> What else can I do, or delete, or uninstall, to at least get back to where I was? Right now I'm basically DIW.
> -- 
> Carl Witthoft
> carl using witthoft.com
> resume: https://app.box.com/file/498153801347
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac using r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list