[R-SIG-Mac] RGtk2 binaries

Lee Godfrey lee @ending from truthfromd@t@@com
Wed May 23 15:53:30 CEST 2018

The easiest way to compile RGtk2 is to use homebrew to install gtk+.

I tried to compile, received the same error as you, installed gtk+ and 
compiled successfully.

On 5/22/18 11:07 PM, Tom Elliott wrote:
> Hi all,
> Since R 3.4, the mac package binaries for RGtk2 have been unavailable. The install log from CRAN shows GTK cannot be found.
> * installing *source* package 'RGtk2' ...
> ** package 'RGtk2' successfully unpacked and MD5 sums checked
> checking for pkg-config... /usr/local/bin/pkg-config
> checking pkg-config is at least version 0.9.0... yes
> checking for INTROSPECTION... no
> checking for GTK... no
> configure: error: GTK version 2.8.0 required
> ERROR: configuration failed for package 'RGtk2'
> * removing '/Volumes/SSD-Data/Builds/R-dev-web/QA/Simon/packages/el-capitan-x86_64/results/3.5/RGtk2.Rcheck/RGtk2'
> Is there any possibility of this being fixed in the (near) future? We have a software package that depends on RGtk2 for the UI, so we are currently stuck forcing them to use R3.2 which is inevitably becoming obsolete as other packages we use require more up-to-date versions of R.
> Thanks,
> - Tom?
> 	[[alternative HTML version deleted]]
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list