[R-SIG-Mac] [SOLVED]: Help! Freezes Consistently When Trying to Execute R Source Script

David Winsemius dwinsemius at comcast.net
Mon Jul 4 17:44:48 CEST 2016

I got a solved-message from Scott.

> On Jul 3, 2016, at 10:57 AM, David Winsemius <dwinsemius at comcast.net> wrote:
> I’m not at the level where I could effectively debug this issue and normally I wouldn’t jump in, but this is a long holiday weekend in the US and it wouldn’t surprise me if Simon didn’t see this for a couple of days.  I would first try deleting R.app from the Applications folder and re-installing it with a clean copy:
> http://r.research.att.com/mavericks/R-3.3-branch/R-GUI-7238-3.3-mavericks-Release.dmg <http://r.research.att.com/mavericks/R-3.3-branch/R-GUI-7238-3.3-mavericks-Release.dmg>
> I do see  “debug” versions but I have never seen it suggested that ordinary users deploy those versions as a first step.
> I would also delete the .Rdata and the .Rapp.history files from your working directory. They have a record of getting corrupted an causing instabilities of obscure causes. They are “hidden files” so you either need to “show them” in the Finder or you need to sue Terminal.app to run a bash session and use mv.

… as well as a suggestion from a different source that `sue`-ing the Terminal might not be appropriate.

> This is the first method:
> Open Terminal found in Finder > Applications > Utilities
> In Terminal, paste the following:          defaults write com.apple.finder AppleShowAllFiles YES

I did wonder about using YES rather than TRUE. That was copied from a google hit.  ISTR that in the past I used TRUE. Didn’t notice the difference until after posting. I later did a search but failed to find documentation that YES was a bash synonym of TRUE. I now pulled up the $man defaults page and it includes this line:

-bool[ean]  Allows the user to specify a boolean as the value for the
                 given preference key.  Value must be TRUE, FALSE, YES, or NO.

So at least Finder.app won’t be sueing me.


> Press return
> Hold the ‘Option/alt’ key, then right click on the Finder icon in the dock and click Relaunch.
> Tor reverse that after deleting those files you would use the same steps with NO substituted for YES. (My preference is for leaving the hidden files shown.)
> Best;
> David Winsemius 
>> On Jul 3, 2016, at 9:41 AM, Scott Novogoratz <sanovogo at gmail.com> wrote:
>> While it started as an occasional freeze, I now can no longer get the R.app Source Script icon to perform.  Each time I click it, I get the spinning pinwheel and need to Force Quit R.
>> Here’s my sessionInfo():
>>> sessionInfo()
>> R version 3.3.1 Patched (2016-06-28 r70858)
>> Platform: x86_64-apple-darwin13.4.0 (64-bit)
>> Running under: OS X El Capitan (10.11.5)
>> locale:
>> [1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8
>> attached base packages:
>> [1] stats     graphics  grDevices utils     datasets  methods  
>> [7] base     
>> loaded via a namespace (and not attached):
>> [1] zoo_1.7-13      xts_0.9-7       grid_3.3.1      IBrokers_0.9-12
>> [5] lattice_0.20-33
>> Here’s my About R info:
>> <PastedGraphic-1.tiff>
>> _______________________________________________
>> R-SIG-Mac mailing list
>> R-SIG-Mac at r-project.org
>> https://stat.ethz.ch/mailman/listinfo/r-sig-mac
> 	[[alternative HTML version deleted]]
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list