[R-SIG-Mac] similar problems installing Rcmdr with R.

John Fox jfox at mcmaster.ca
Tue Sep 24 18:24:37 CEST 2013

Dear Mark,

As was the case with other similar recent problems, this issue appears to
pertain to the tcltk package and only indirectly to the Rcmdr. You can
verify that by trying to load tcltk directly via library(tcltk).

I assume that when you say that you updated everything, that included
running Mac OS X Software Update.

As you point out, your problem appears to be similar to an earlier problem
reported by Sarah Hardy at
0-1-on-a-mac-os-x-10-8-3>. In her case, fixing the files permissions fixed
the problem, as indicated in the same thread. Did 

	sudo chmod a+rx /usr/local/*

work for you as it did for her? (I see that Rodney Sparapani has just made
an equivalent suggestion.)

Another question, assuming that this fix works, is why you experienced the
problem in the first place. In Sarah's case, the permissions were screwed up
by MacPorts.

I'm copying this response to Simon Urbanek to make sure that he's aware of
this thread (though there's no need for Simon to respond if fixing the
permissions works).

I hope this helps,

> -----Original Message-----
> From: r-sig-mac-bounces at r-project.org [mailto:r-sig-mac-bounces at r-
> project.org] On Behalf Of Hebblewhite, Mark
> Sent: Tuesday, September 24, 2013 8:46 AM
> To: r-sig-mac at r-project.org
> Subject: [R-SIG-Mac] similar problems installing Rcmdr with R.
> I have recently installed R 3.0.1 on my MacBook Pro OS  X 10.8.5 (very
> new
> version), and am experiencing similar problems that Sarah Hardy posted
> almost a month ago. I similarly teach an introduction to R course to
> about
> 20 graduate students, many of whom use Mac's, but luckily not this
> semester. I have used R for > 6 years, but am new (1 year) to MACs, but
> expect that if I'm having this problem with 10.8.5, then others must be
> too.
>  I have read through the entire thread of solutions for this problem on
> this list serve, the notes on Joseph Fox's webpage
> (http://socserv.socsci.mcmaster.ca/jfox/Misc/Rcmdr/installation-
> notes.html)
>  and have tried to do my absolute best to fix the problem myself and
> with
> a colleague.  Here is a summary of my particulars:
> 1. I have a Mac OS X 10.8.5, and updated everything today.
> 2. I also installed the XQuartz package today, version 2.7.4 from last
> Sept 2012.
> 3. I uninstalled R manually from my MAC (both moving old version to the
> trash and cleaning out R directories)
> 4. I re-installed R (R 3.0.1 GUI 1.61 Snow Leopard build (6492)
> directly
> from the CRAN (Italy) using this command:
> install.packages("Rcmdr", dependencies = TRUE)
> 	5. I then followed the instructions for downloading Rcmdr package
> in both
> the command line and from the R.app menu. I have also tried it from two
> different CRAN sites. It downloaded and installed apparently fine as it
> appears in my library files (version dated august 22)
> The downloaded binary packages are in
> 	/var/folders/30/710s5wkn59959r6mfhmssyvrc0w434/T//RtmpGry9Bb/downl
> oaded_pa
> ckages
> 6. 	No matter what series of these steps I take, I receive the similar
> error message as others:
>  library(Rcmdr)
> Error : .onLoad failed in loadNamespace() for 'tcltk', details:
>   call: dyn.load(file, DLLpath = DLLpath, ...)
>   error: unable to load shared object
> '/Library/Frameworks/R.framework/Versions/3.0/Resources/library/tcltk/l
> ibs/
> tcltk.so':
> dlopen(/Library/Frameworks/R.framework/Versions/3.0/Resources/library/t
> cltk
> /libs/tcltk.so, 10): Library not loaded: /usr/local/lib/libtcl8.6.dylib
>   Referenced from:
> /Library/Frameworks/R.framework/Versions/3.0/Resources/library/tcltk/li
> bs/t
> cltk.so
>   Reason: no suitable image found.  Did find:
> 	/usr/local/lib/libtcl8.6.dylib: stat() failed with errno=13
> 	/usr/local/lib/libtcl8.6.dylib: stat() failed with errno=13
> Error: package or namespace load failed for ŒRcmdr¹
> 7. From previous posts on this list serve
> [http://grokbase.com/t/r/r-sig-mac/138nv3tj17/unable-to-load-rcmdr-
> with-r-3
> -0-1-on-a-mac-os-x-10-8-3] I followed this set of instructions to see
> whether there were problems with my permissions:
> > system("ls -ld /usr/local /usr/local/lib /usr/local/lib/libtcl*")
> ls: /usr/local/lib: Permission denied
> ls: /usr/local/lib/libtcl*: Permission denied
> drwx------  8 root  wheel  272 Sep 24 10:21 /usr/local
> 8. But in my disk utilities I can see no clear disk permissions related
> to
> R. I ran repair disk permissions earlier today and there was 1 R
> problem
> but that¹s been apparently fixed.
> My own troubleshooting abilities are at an end.
> As best I can determine, it seems as if the XQuartz version I
> downloaded
> might not be working with my Mac OSX 10.8.5, but beyond that I really
> have
> no clue how best to proceed.
> thanks very much for your patience with this problem and with me if my
> query is naïve in anyway.
> Sincerely,
> Mark Hebblewhite
> >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
> Wildlife Biology Program
> Department of Ecosystem and Conservation Sciences
> College of Forestry and Conservation
> University of Montana
> 32 Campus Drive
> Missoula, MT, 59812
> Phone: 1-406-243-6675
> Email: mark.hebblewhite at umontana.edu
> Website: http://www.cfc.umt.edu/Heblab/
> >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

More information about the R-SIG-Mac mailing list