[R-SIG-Mac] segfaults while editing code scripts on 10.9 mavericks

Alexander Guczka alexander.guczka at uni-hamburg.de
Fri Nov 15 13:12:08 CET 2013

Dear R-SIG,

I have met some Problems since I updated to OSX Mavericks. From time to time does R crash with a "segfault" if I understand it correctly. I think that some of the crashes are associated with the R-GUI.

One recurring (but not completely reproducible) crash happens, when I edit code-documents/scripts and try to search and replace more than one element at a time. I tried to reduce the amount of Elements to "replace all" but with no effect. Some days ago I switched to another code editor because of that.

What happens? R stops working the second I click "replace all" and shows segfault –  "memory not mapped"

The other editor (sub-etha-edit) warns me that in R-GUI produced .R-scripts have different/not consistent line ending formats and suggest changing all to linux-style LF. Since changing one of my bigger scripts in sub-etha-edit "replace all" works again in R-GUI. Maybe this information helps. 

I had a lot of crashes with 3.0.1 on Mavericks, changed to 3.0.2 which works really good most of the time. Because of the crash problem mentioned above I tried updating to a patched version of 3.0.2 with no significant effect (pun intended). 

current versions:
R version 3.0.2 Patched (2013-11-11 r64202) -- "Frisbee Sailing"
R.app GUI 1.62 (6596) x86_64-apple-darwin10.8.0  

Best wishes,
Alexander Guczka

More information about the R-SIG-Mac mailing list