[R-SIG-Mac] R Update - FAILED- HELP!!!

Jean Jang jeanwaijang at gmail.com
Sun Oct 7 02:04:04 CEST 2012

Thanks for your reply,

1) I tried R --vanilla in the terminal and received the below message.  
So it looks like the latest version of R is updated "Roasted  
Marshmallows". Thank you for your explanations, because I only started  
using R this year, an obvious beginner.

Last login: Wed Jan  3 02:19:12 on console
jeans-macbook-104:~ jean$ R --vanilla

R version 2.15.1 (2012-06-22) -- "Roasted Marshmallows"
Copyright (C) 2012 The R Foundation for Statistical Computing
ISBN 3-900051-07-0
Platform: i386-apple-darwin9.8.0/i386 (32-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

   Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

2) I would really like to get back to the console with RStudio how I  
had my scripts saved before eventually. Because this is how I know to  
work with R - in RStudio.

3) The q() option does not bother me. Right now there are 3 icons, an  
apple tech told that I must drag the icon to trash and then reload a  
newer version of a program. Please let me know if I should do so.  
(RStudio, R, R64).

4) I tried launching R studio again but as mentioned I was receiving  
the default message which gives me the option to 'relaunch', 'report  
(send error to apple)' or 'cancel'. The problem details :

Process:         RStudio [816]
Path:            /Applications/RStudio.app/Contents/MacOS/RStudio
Identifier:      org.rstudio.RStudio
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [72]

Interval Since Last Report:          994 sec
Crashes Since Last Report:           1
Per-App Interval Since Last Report:  0 sec
Per-App Crashes Since Last Report:   1

Date/Time:       2012-10-06 13:59:24.444 -1000
OS Version:      Mac OS X 10.5.8 (9L31a)
Report Version:  6
Anonymous UUID:  59FB002A-00E8-4C55-9BC8-DBE76B413D8D

Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
   unknown required load command 0x80000022
And system configuration:

Model: MacBook5,1, BootROM MB51.007D.B03, 2 processors, Intel Core 2  
Duo, 2 GHz, 2 GB
Graphics: kHW_NVidiaGeForce9400MItem, NVIDIA GeForce 9400M,  
sppci_pci_device, 256 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D),  
Broadcom BCM43xx 1.0 (
Bluetooth: Version 2.1.9f10, 2 service, 1 devices, 1 incoming serial  
Network Service: AirPort, AirPort, en1
Serial ATA Device: Hitachi HTS543216L9SA02, 149.05 GB
Serial ATA Device: HL-DT-ST DVDRW  GS21N
USB Device: Built-in iSight, (null) mA
USB Device: My Passport 070A, (null) mA
USB Device: BRCM2046 Hub, (null) mA
USB Device: Bluetooth USB Host Controller, (null) mA
USB Device: Apple Internal Keyboard / Trackpad, (null) mA
USB Device: IR Receiver, (null) mA

5) I just typed the commands you suggested in the terminal and they  
worked - all of them.

6) In applications I opened R (silver blue icon) and the console  
opened up, looks like it works fine.

7) All I need now is the RStudio to work as it did and all my  
beautiful scripts to show up as it was before I tried update.

Many thanks, I look forward to hearing from you.


On 6-Oct-12, at 1:26 PM, R. Michael Weylandt wrote:

> On Sun, Oct 7, 2012 at 12:04 AM, Jean Jang <jeanwaijang at gmail.com>  
> wrote:
>> Hi Thanks for your attention.
>> I avoided updating because I heard of similar problems. But found I  
>> had to
>> execute certain things. I can't find the R download in the folder I
>> initially tried but I remember it telling me that it could not finish
>> because the program was in use. I found this R icon next to my  
>> applications
>> folder and it is Rstudio 0.96.331 but says modified 27 Aug 12 - not  
>> sure if
>> this is the version I tried today.
>> I do not know how to 'R --vanilla'
>> I would like to be able to run RStudio this is what I know of and was
>> running from before.
>> I downloaded the latest version of R from the CRAN website (R-2.15.1
>> signed.pkg) and restarted.
>> But the RStudio icon I had in my dock will still not launch. Now in  
>> my
>> applications folder I have RStudio (big blue ball) and two icons  
>> for 'R' -
>> one with just 'R' the other with 'R64'. Should I be putting some of  
>> these in
>> the trash?
>> What should I do now?
>> Jean
> Let me try to make this clearer: there are three pieces of software
> working together:
> i) R the cross platform interpreted language. When we say "start R"
> this is really what we mean
> ii) The R Mac GUI provided by Simon et al. which comes bundled with R
> in the official installer, but is not required for use.
> iii) RStudio which is a different GUI/IDE provided by other people
> entirely which has its own support system distinct from these help
> lists.
> Both ii and iii start an instance of i but don't give you direct
> access to it, instead filtering your commands and R's output through a
> nicer user interface. Working through terminal gives you direct
> exposure to i. (I'm simplifying greatly, but just go with it) If i
> doesn't work, ii and iii can't, so that's the first thing to check.
> If you can go back to terminal and type
> R --vanilla
> where you just typed
> R
> before, you are doing as Prof Ripley asks (and as I should have
> noted). Once you do that, try a few basic R commands:
> 3 + 1:5
> rnorm(10)
> plot(5:1)
> and make sure they work. Don't worry about the message starting with
> "R Version 2.13.1" and ending with "Type q() to quit R." Anything
> which appears before or after those lines, please report. From what
> you've said, it sounds like R (in the sense i above) is still working
> fine.
> Then lets see if the GUI is working. In your applications folder by
> way of the dock, try starting Simon's GUI by clicking on the
> blue/purple R with the silver ring behind it (either should be fine).
> If this fails, but the terminal way works, that's a different bit of
> software that we need to figure out. Finally, if those work, we can
> look at RStudio, but you might be better served by using their support
> systems.
> I'm not sure how you got in this mess -- I really don't know what the
> "top tool bar" which suggest you update R is, but I and many others
> have never had update problems thanks to the wonderful work of Simon
> and Prof Ripley et al, and I think you might be convinced there's a
> problem where there actually isn't one. You certainly haven't actually
> demonstrated existence of a problem to this point. Usually when
> programs truly crash on a Mac, there's an option to "report to apple"
> and to see system logs: if you are seeing those options, we'd really
> appreciate that knowledge, and, even more importantly, the transcript
> of the  logs.
> And, in the last, just to confirm, you should be installing from this
> site and none other:
> http://cran.r-project.org/bin/macosx/
> There are other mirrors you can use when we get things sorted, but
> lets cut out one possible (though not actually all that possible)
> source of error for now.
> Michael

More information about the R-SIG-Mac mailing list