[R-SIG-Mac] R Update - FAILED- HELP!!!

R. Michael Weylandt michael.weylandt at gmail.com
Sun Oct 7 01:26:57 CEST 2012

On Sun, Oct 7, 2012 at 12:04 AM, Jean Jang <jeanwaijang at gmail.com> wrote:
> Hi Thanks for your attention.
> I avoided updating because I heard of similar problems. But found I had to
> execute certain things. I can't find the R download in the folder I
> initially tried but I remember it telling me that it could not finish
> because the program was in use. I found this R icon next to my applications
> folder and it is Rstudio 0.96.331 but says modified 27 Aug 12 - not sure if
> this is the version I tried today.
> I do not know how to 'R --vanilla'
> I would like to be able to run RStudio this is what I know of and was
> running from before.
> I downloaded the latest version of R from the CRAN website (R-2.15.1
> signed.pkg) and restarted.
> But the RStudio icon I had in my dock will still not launch. Now in my
> applications folder I have RStudio (big blue ball) and two icons for 'R' -
> one with just 'R' the other with 'R64'. Should I be putting some of these in
> the trash?
> What should I do now?
> Jean

Let me try to make this clearer: there are three pieces of software
working together:

i) R the cross platform interpreted language. When we say "start R"
this is really what we mean
ii) The R Mac GUI provided by Simon et al. which comes bundled with R
in the official installer, but is not required for use.
iii) RStudio which is a different GUI/IDE provided by other people
entirely which has its own support system distinct from these help

Both ii and iii start an instance of i but don't give you direct
access to it, instead filtering your commands and R's output through a
nicer user interface. Working through terminal gives you direct
exposure to i. (I'm simplifying greatly, but just go with it) If i
doesn't work, ii and iii can't, so that's the first thing to check.

If you can go back to terminal and type

R --vanilla

where you just typed


before, you are doing as Prof Ripley asks (and as I should have
noted). Once you do that, try a few basic R commands:

3 + 1:5



and make sure they work. Don't worry about the message starting with

"R Version 2.13.1" and ending with "Type q() to quit R." Anything
which appears before or after those lines, please report. From what
you've said, it sounds like R (in the sense i above) is still working

Then lets see if the GUI is working. In your applications folder by
way of the dock, try starting Simon's GUI by clicking on the
blue/purple R with the silver ring behind it (either should be fine).
If this fails, but the terminal way works, that's a different bit of
software that we need to figure out. Finally, if those work, we can
look at RStudio, but you might be better served by using their support

I'm not sure how you got in this mess -- I really don't know what the
"top tool bar" which suggest you update R is, but I and many others
have never had update problems thanks to the wonderful work of Simon
and Prof Ripley et al, and I think you might be convinced there's a
problem where there actually isn't one. You certainly haven't actually
demonstrated existence of a problem to this point. Usually when
programs truly crash on a Mac, there's an option to "report to apple"
and to see system logs: if you are seeing those options, we'd really
appreciate that knowledge, and, even more importantly, the transcript
of the  logs.

And, in the last, just to confirm, you should be installing from this
site and none other:


There are other mirrors you can use when we get things sorted, but
lets cut out one possible (though not actually all that possible)
source of error for now.


More information about the R-SIG-Mac mailing list