[R-SIG-Mac] R Update - FAILED- HELP!!!

R. Michael Weylandt michael.weylandt at gmail.com
Sun Oct 7 02:20:54 CEST 2012

On Sun, Oct 7, 2012 at 1:04 AM, Jean Jang <jeanwaijang at gmail.com> wrote:
> Thanks for your reply,
> 1) I tried R --vanilla in the terminal and received the below message. So it
> looks like the latest version of R is updated "Roasted Marshmallows". Thank
> you for your explanations, because I only started using R this year, an
> obvious beginner.
> Last login: Wed Jan  3 02:19:12 on console
> jeans-macbook-104:~ jean$ R --vanilla
> R version 2.15.1 (2012-06-22) -- "Roasted Marshmallows"
> Copyright (C) 2012 The R Foundation for Statistical Computing
> ISBN 3-900051-07-0
> Platform: i386-apple-darwin9.8.0/i386 (32-bit)
> R is free software and comes with ABSOLUTELY NO WARRANTY.
> You are welcome to redistribute it under certain conditions.
> Type 'license()' or 'licence()' for distribution details.
>   Natural language support but running in an English locale
> R is a collaborative project with many contributors.
> Type 'contributors()' for more information and
> 'citation()' on how to cite R or R packages in publications.
> Type 'demo()' for some demos, 'help()' for on-line help, or
> 'help.start()' for an HTML browser interface to help.
> Type 'q()' to quit R.

Yes this is good and all as it should be.

> 2) I would really like to get back to the console with RStudio how I had my
> scripts saved before eventually. Because this is how I know to work with R -
> in RStudio.

As I explained before, this isn't RStudio help. RStudio is a different
product than R made by different people. We've verified that both R
itself and the R GUI work just fine, so you really should be asking at

> 3) The q() option does not bother me. Right now there are 3 icons, an apple
> tech told that I must drag the icon to trash and then reload a newer version
> of a program. Please let me know if I should do so. (RStudio, R, R64).

No, as I've explained. These are different pieces of software which do
different things. They can and should coexist peacefully. (The
difference between R and R64 is the difference between a 32 and a 64
bit build if the apple folks ask -- don't worry about that for now)

> 4) I tried launching R studio again but as mentioned I was receiving the
> default message which gives me the option to 'relaunch', 'report (send error
> to apple)' or 'cancel'. The problem details :
> Process:         RStudio [816]
> Path:            /Applications/RStudio.app/Contents/MacOS/RStudio
> Identifier:      org.rstudio.RStudio
> Version:         ??? (???)
> Code Type:       X86-64 (Native)
> Parent Process:  launchd [72]
> Interval Since Last Report:          994 sec
> Crashes Since Last Report:           1
> Per-App Interval Since Last Report:  0 sec
> Per-App Crashes Since Last Report:   1
> Date/Time:       2012-10-06 13:59:24.444 -1000
> OS Version:      Mac OS X 10.5.8 (9L31a)
> Report Version:  6
> Anonymous UUID:  59FB002A-00E8-4C55-9BC8-DBE76B413D8D
> Exception Codes: 0x0000000000000002, 0x0000000000000000
> Crashed Thread:  0
> Dyld Error Message:
>   unknown required load command 0x80000022
> ---------------------
> And system configuration:
> Model: MacBook5,1, BootROM MB51.007D.B03, 2 processors, Intel Core 2 Duo, 2
> GHz, 2 GB
> Graphics: kHW_NVidiaGeForce9400MItem, NVIDIA GeForce 9400M,
> sppci_pci_device, 256 MB
> Memory Module: global_name
> AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D),
> Broadcom BCM43xx 1.0 (
> Bluetooth: Version 2.1.9f10, 2 service, 1 devices, 1 incoming serial ports
> Network Service: AirPort, AirPort, en1
> Serial ATA Device: Hitachi HTS543216L9SA02, 149.05 GB
> Serial ATA Device: HL-DT-ST DVDRW  GS21N
> USB Device: Built-in iSight, (null) mA
> USB Device: My Passport 070A, (null) mA
> USB Device: BRCM2046 Hub, (null) mA
> USB Device: Bluetooth USB Host Controller, (null) mA
> USB Device: Apple Internal Keyboard / Trackpad, (null) mA
> USB Device: IR Receiver, (null) mA

Again, this is an RStudio problem, not an R problem. Do be prepared to
supply this to them if they ask however.

> 5) I just typed the commands you suggested in the terminal and they worked -
> all of them.
> 6) In applications I opened R (silver blue icon) and the console opened up,
> looks like it works fine.

So R itself works and the R Gui works. (i and ii in the schema
explained before)

> 7) All I need now is the RStudio to work as it did and all my beautiful
> scripts to show up as it was before I tried update.

Try reinstalling RStudio now from their binaries. This won't touch
your version of R.

I believe you can recover your scripts from the hidden directory


if you think the new install might clobber them, but I'm not entirely
sure how to go about doing that and, once again, I'd ask the RStudio
people. I've worked with them before and they're very helpful and

Again, let me just reiterate: R is a backend which can have many
clients. (R.app, Emacs, RStudio, etc.) We've verified both R and R.app
(the GUI) work, so the problem is now certainly in RStudio, not R.


More information about the R-SIG-Mac mailing list