[R-SIG-Mac] Error updating packages

Ista Zahn istazahn at gmail.com
Fri Feb 29 16:55:57 CET 2008

Thank you for the quick response Simon. Unfortunately I'm still having  
problems. When I try to run update using the GUI (after clicking on  
the lock in the GUI and authenticating) I get a message saying that it  
is "not possible to install binary packages from a remote repository  
as root."

I've tried starting R from the terminal as root (sudo R) and issuing  
the update.packages() command, but I still get the "cannot remove  
prior installation" error.

I've even tried modifying the permissions on /Library/Frameworks/ 
R.framework/Versions/2.6/Resources/library, without effect.

This is actually even more worrisome than I first thought, because  
after the installation fails I find that the package that cannot be  
removed is no longer installed! For example, after the first error the  
boot package was no longer installed. When I reissued the  
update.packages command again the error message skipped to the next  
package in the list (i.e., "Error: cannot remove prior installation of  
package ‘lattice’").

I was able to reinstall boot and lattice without incident, but I'm  
finding the whole business  very strange.

Thanks again for the quick response, and for any additional help you  
might be able to offer.
On Feb 29, 2008, at 10:04 AM, Simon Urbanek wrote:

> On Feb 29, 2008, at 9:43 AM, Ista Zahn wrote:
>> Hi,
>> When I try to update packages I get an error saying
>> Error: cannot remove prior installation of package ‘boot’
>> This happens both when I use the GUI and when I issue
>> update.packages() from the command prompt. Does anyone know what the
>> problem might be? I'm running R 2.6.2 on OS X 10.5.2.
> It is highly likely that you don't have enough permissions to delete  
> the "boot" package. Login as admin and/or root and remove the  
> package. Alternatively, if you are admin, you can authorize as root  
> (by clicking on the lock in the R GUI toolbar) and perform the  
> upgrade. Be sure to de-authorize after you're done (by clicking on  
> the lock symbol again).
> Cheers,
> Simon

More information about the R-SIG-Mac mailing list