[R-SIG-Mac] Cannot get Tktable to work to run affylmGUI/limmaGUI

David Roberts drdadr at yahoo.com
Thu Sep 6 19:46:13 CEST 2007

I am a novice level user with R and I'm also new to OS
X. I installed R and Bioconductor on my MacBook Pro
and subsequently learned I needed some additional
components to run affylmGUI. I then installed XCode
and X11 from the OS X Tiger DVD, then moved on to
installing the required BWidgets and Tktable. Bwidgets
was fine, but when I tried to make and install Tktable
I got the following error:

drdadr:/usr/local/lib/Tktable2.9 drfermin$ sudo make
 /usr/bin/install -c libTktable2.9.dylib
install: libTktable2.9.dylib and
/usr/local/lib/Tktable2.9/libTktable2.9.dylib are the
same file
 : /usr/local/lib/Tktable2.9/libTktable2.9.dylib
 Install tkTable.tcl
/usr/bin/install -c -m 644 pkgIndex.tcl
 Install license.txt
install: ./license.txt and
/usr/local/lib/Tktable2.9/license.txt are the same
 Install README.txt
install: ./README.txt and
/usr/local/lib/Tktable2.9/README.txt are the same file
make: *** [install-binaries] Error 64

I went back to the R console and added
/usr/local/lib/Tktable2.9 to the
tclvalue("auto_path"), but running affylmGUI() on X11
resulted in "cannot find tktable."

I tried compiling to a different directory using the
--prefix flag on configure, to no avail.

Finally, I found precompiled binaries of Tktable that
I downloaded and unpacked into the
/usr/local/lib/Tktable2.9 directory, but the command
tclRequire("Tktable") in R still resulted in:

Warning message:
Tcl package 'Tktable' not found in:

What am I doing wrong? Could it have something to do
with file permissions on OS X, since I have to use
"sudo" to do every commmand? This is really holding up
my work. Any assistance is much appreciated; I
apologize if this is really a simple problem.


More information about the R-SIG-Mac mailing list