[R-SIG-Mac] Problems when R quits

Simon Urbanek simon.urbanek at r-project.org
Sun Apr 8 23:17:28 CEST 2007


as the message tells you this has nothing to do with the R  
installation, but with your .Last function in your workspace. Simply  
remote the offending .Last with
and everything should be fine. As the help page warns, .Last should  
be well-written, otherwise expect trouble ;).


On Apr 8, 2007, at 2:37 PM, Kate wrote:

> Dear List,
> I have begun to have problems with R when I try and quit. I receive  
> the following message whether or not I choose to save the workspace  
> image. I am running R version 2.4.1 on OSX version 10.4.9.
>> q()
> Save workspace image? [y/n/c]: y
> Error in .Last() : could not find function "finalizeSession"
> The onlt way I can exit R is to force a quit.
> I have tried uninstalling R and reloading from scratch; however I'm  
> not sure that I am doing this correctly.   I couldn't find an  
> uninstaller so I deleted the
> R.app in the applications
> R.framework in the library framework package
> The packages in the receipts.
> The new R does not have all the packages my old version had when I  
> start it up, but it is loading a restored workspace.
> I have tried reinstalling twice now and I get the same error  
> message when I try and quit.
> Does anyone know what it is I need to do to get the program to save  
> correctly?
> Many Thanks,
> Kate
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list