[R-SIG-Mac] R CMD INSTALL cannot find netcdf library

jiho jo.irisson at gmail.com
Wed Sep 6 09:23:40 CEST 2006

On 05 Sep 2006, at 20:47 , Simon Urbanek wrote:
> On Sep 5, 2006, at 4:42 AM, jiho wrote:
>> I tried to install RNetCDF binary package but when I try to load it
>> after installation, it gives this message
> [...]
> Thanks, I have fixed that now - the binary contained only i386  
> version of netcdf. The mirrors should be updated soon, for the  
> moment you can install it via
> install.packages("RNetCDF",,"http://r.research.att.com")
> (Note: you still need /usr/local/etc/udunits.dat same as with  
> udunits package).

Thanks for this. Actually I got ncdf and RNetCDF to compile by using  
directly R CMD INSTALL so I finally got the functionality I wanted  
(and managed to output some very nice graphics actually... ahhhh I  
love R plotting functions! ;-) )

>> [...]
>> Therefore I tried the command:
>> 	install.packages(c("RNetCDF"),lib="/Library/Frameworks/Resources/
>> library/",contriburl=contrib.url(getOption
>> ("repos"),"source"),type='source',dependencies=FALSE,configure.args=" 
>> --w
>> ith-netcdf-include=/sw/include/ --with-netcdf-lib=/sw/lib/")
>> but to no avail, I still get the same error message:
> You actually discovered a bug in install.packages - unnamed  
> configure arguments were not passed on. Thanks, this is now fixed  
> in 2.4.0 alpha and R-devel.

So it seems, because it worked from R CMD INSTALL. Thank you for  
fixing this so fast.



More information about the R-SIG-Mac mailing list