[R-SIG-Mac] R CMD INSTALL cannot find netcdf library

Simon Urbanek simon.urbanek at r-project.org
Tue Sep 5 20:47:54 CEST 2006


On Sep 5, 2006, at 4:42 AM, jiho wrote:

> Hi,
> I tried to install RNetCDF binary package but when I try to load it
> after installation, it gives this message
> 	> library("RNetCDF")
> 	Error in dyn.load(x, as.logical(local), as.logical(now)) :
> 		unable to load shared library '/Library/Frameworks/R.framework/
> Versions/2.3/Resources/library/RNetCDF/libs/ppc/RNetCDF.so':
> 	dlopen(/Library/Frameworks/R.framework/Versions/2.3/Resources/
> library/RNetCDF/libs/ppc/RNetCDF.so, 6): Symbol not found:  
> _nc_inq_dimid
> 	  Referenced from: /Library/Frameworks/R.framework/Versions/2.3/
> Resources/library/RNetCDF/libs/ppc/RNetCDF.so
> 	  Expected in: flat namespace
> 	Error in library("RNetCDF") : .First.lib failed for 'RNetCDF'

Thanks, I have fixed that now - the binary contained only i386  
version of netcdf. The mirrors should be updated soon, for the moment  
you can install it via


(Note: you still need /usr/local/etc/udunits.dat same as with udunits  

> [...]
> Therefore I tried the command:
> 	install.packages(c("RNetCDF"),lib="/Library/Frameworks/Resources/
> library/",contriburl=contrib.url(getOption
> ("repos"),"source"),type='source',dependencies=FALSE,configure.args="- 
> -w
> ith-netcdf-include=/sw/include/ --with-netcdf-lib=/sw/lib/")
> but to no avail, I still get the same error message:

You actually discovered a bug in install.packages - unnamed configure  
arguments were not passed on. Thanks, this is now fixed in 2.4.0  
alpha and R-devel.


More information about the R-SIG-Mac mailing list