[R-SIG-Mac] Link needed to use beta test build of R-2.3.1

Simon Urbanek simon.urbanek at r-project.org
Mon May 29 00:19:01 CEST 2006

Thanks, Doug.

In fact this is a bug in the nightly path fix-up, because the binary  
is not supposed to have any links to /usr/local/gcc4.0 as it is not  
required for running R. I have fixed it so the next build should be ok.

I'm glad that at least someone actually tests the beta/RC ..


On May 27, 2006, at 6:04 PM, Douglas Bates wrote:

> I downloaded the universal nightly build of R-patched from
> http://r.research.att.com/, which identifies itself as
> Version 2.3.1 RC (2006-05-26 r38204)
> After installing it on an Intel Mac I found that I couldn't run it
> because it tried to dyld a library that wasn't present.  I played
> around with removing and installing the gcc403 package a bit then
> realized that it was a matter of the name and could be solved by
> adding a symlink
> cd /usr/local/gcc4.0
> sudo mkdir i686-apple-darwin8
> cd i686-apple-darwin8
> sudo ln -s ../lib .
> The problem is that the name /usr/local/gcc4.0/i686-apple-darwin/lib
> is hardwired in the i686 executable but that directory is not
> installed by the gcc403 package.
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list