[R-SIG-Mac] RMySQL won't install

Simon Urbanek simon.urbanek at r-project.org
Mon Aug 21 19:00:57 CEST 2006

On Aug 21, 2006, at 4:54 AM, Casey Dunn wrote:

> Hi-
> 	I am also having trouble installing RMySQL (OS X 10.4.7, R2.3.1,
> MySQL 5.0.24, RMySQL 0.5-7, all 32 bit PPC). DBI loads fine, but when
> I try to load RMySQL I get the following:
> Error in dyn.load(x, as.logical(local), as.logical(now)) :
> 	unable to load shared library '/Library/Frameworks/R.framework/
> Versions/2.3/Resources/library/RMySQL/libs/ppc/RMySQL.so':
>    dlopen(/Library/Frameworks/R.framework/Versions/2.3/Resources/
> library/RMySQL/libs/ppc/RMySQL.so, 6): Symbol not found:  
> _load_defaults
>    Referenced from: /Library/Frameworks/R.framework/Versions/2.3/
> Resources/library/RMySQL/libs/ppc/RMySQL.so
>    Expected in: flat namespace
> Error in library(RMySQL) : .First.lib failed for 'RMySQL'

I can confirm that. It was a problem on the build machine that didn't  
have mysql for ppc. I have fixed that (by creating an universal mysql  
devel kit) so it should be available on the mirrors shortly. You can  
fetch the correct RMySQL binary right now with


> I downloaded the source for RMySQL, compiled it (gcc 4.0.0), and  
> got the exact same result. I also tried with MySQL 5.0.20 and MySQL  
> 4.0.21, and again got the same result.

My guess would be that you either don't have the correct libraries or  
there is another RMySQL version in your system somewhere. I have no  
problem re-compiling RMySQL from sources. This works for me (mysql  

PKG_CPPFLAGS=-I/usr/local/mysql/include PKG_LIBS="-L/usr/local/mysql/ 
lib -lmysqlclient" R CMD INSTALL RMySQL_0.5-7.tar.gz


More information about the R-SIG-Mac mailing list