[R-SIG-Mac] RMySQL won't install

Casey Dunn cdunn at hawaii.edu
Mon Aug 21 10:54:33 CEST 2006

	I am also having trouble installing RMySQL (OS X 10.4.7, R2.3.1,  
MySQL 5.0.24, RMySQL 0.5-7, all 32 bit PPC). DBI loads fine, but when  
I try to load RMySQL I get the following:
Error in dyn.load(x, as.logical(local), as.logical(now)) :
	unable to load shared library '/Library/Frameworks/R.framework/ 
library/RMySQL/libs/ppc/RMySQL.so, 6): Symbol not found: _load_defaults
   Referenced from: /Library/Frameworks/R.framework/Versions/2.3/ 
   Expected in: flat namespace
Error in library(RMySQL) : .First.lib failed for 'RMySQL'

I downloaded the source for RMySQL, compiled it (gcc 4.0.0), and got  
the exact same result. I also tried with MySQL 5.0.20 and MySQL  
4.0.21, and again got the same result.

Was anyone else able to resolve this problem? Are others able to get  
RMySQL running on similar machines without encountering this problem?

A couple possibilities come to mind:

-Something is broken about my system that prevents the linking of all  
the necessary system libraries (eg different versions of gcc were used).
-Something wrong with my mysql installation that is making the  
libraries inaccessible.
-The "TODO" comments in RS-MySQL.c regarding OS X mean that the  
RMySQL implementation on OS X is not complete.

If this is a system libraries issue, I wonder if it's related to the  
libmysqlclient.a problems that were encountered late last year (see  
"RMySQL problem" thread from November 18 2005).


Dr. Casey Dunn

More information about the R-SIG-Mac mailing list