[R-SIG-Mac] Rgraphviz installation problem

Michael Kubovy kubovy at virginia.edu
Fri Aug 18 04:19:42 CEST 2006

Dear R-sig-mac people,

Following Seth Falconer's advice on this list in March, I tried to  
install with

sudo R CMD INSTALL --configure-args='--with-graphviz=/Applications/ 
\~LocalApps/graphics/Graphviz/Graphviz.app/' Rgraphviz_1.10.0.tar.gz
which I had just downloaded
to which it responded
* Installing *binary* package 'Rgraphviz' ...
* DONE (Rgraphviz)

When I issued library(Rgraphviz)

I got

Loading required package: graph
Loading required package: Ruuid
Error in dyn.load(x, as.logical(local), as.logical(now)) :
	unable to load shared library '/Library/Frameworks/R.framework/ 
library/Rgraphviz/libs/ppc/Rgraphviz.so, 6): Library not loaded: /usr/ 
   Referenced from: /usr/local/lib/graphviz/libgvc.2.dylib
   Reason: image not found
Error: .onLoad failed in 'loadNamespace' for 'Rgraphviz'
Error: package/namespace load failed for 'Rgraphviz'

Seth's other advice reads: "for the autoconf tools to work, you need  
the pkg-config program installed and PKG_CONFIG_PATH set  
appropriately (/blah/lib/pkgconfig)."

If this is still the best advice, could someone tell me what to do?

I tried
sudo port install pkgconfig
--->  Unpacking tgz archive for pkgconfig 0.20_0
--->  Cleaning pkgconfig

But although 'locate pkgconfig' gives me a long list of files, 'which  
pkgconfig' says 'pkgconfig: Command not found.'

What next? Seth says to set PKG_CONFIG_PATH to /blah/lib/pkgconfig,  
which I don't know how to do.

BTW, my shell is tcsh, my os is 10.4.7, and R is Version 2.3.1  
Professor Michael Kubovy
University of Virginia
Department of Psychology
USPS:     P.O.Box 400400    Charlottesville, VA 22904-4400
Parcels:    Room 102        Gilmer Hall
         McCormick Road    Charlottesville, VA 22903
Office:    B011    +1-434-982-4729
Lab:        B019    +1-434-982-4751
Fax:        +1-434-982-4766
WWW:    http://www.people.virginia.edu/~mk9y/

More information about the R-SIG-Mac mailing list