[R-SIG-Mac] Segmentation Fault & Illegal Instruction

Paul DeBruicker paul at woodgasllc.com
Fri Nov 5 17:56:59 CET 2004


When attempting to connect to a user level data source using  RODBC 
1.1-2,  I get a segmentation fault or illegal instruction and crash R.  
As in:

R : Copyright 2004, The R Foundation for Statistical Computing
Version 2.0.0  (2004-10-04), ISBN 3-900051-07-0

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for a HTML browser interface to help.
Type 'q()' to quit R.

Loading required package: grDevices
lib> library(RODBC)
 > cha<-odbcConnect("jeff")
Segmentation fault

When I run "sudo R" this is the result:
 > cha<-odbcConnect("jeff")
Illegal instruction

When I try to connect to a system level data source with the same setup 
as the user level data source (with and without "sudo R"), I get some 
errors.  As in:

 > library(RODBC)
 > cha<-odbcConnect("pgjeffect")
Warning messages:
1: [RODBC] ERROR: state IM002, code 0, message [iODBC][Driver 
Manager]Data source name not found and no default driver specified. 
Driver could not be loaded
2: ODBC connection failed in: odbcDriverConnect(st, case = case, 
believeNRows = believeNRows)

Both data sources work great when accessed through Microsoft Query.  
iODBC Test.command hook up to the databases, and IODBC Adminsitrator 
"Test" reports "The connection DSN was tested successfully, and can be 
used at this time."  I have stored the username and password in the 
odbc.ini file.

I would believe it is a user error, as I only have a vague idea of how 
what I'm trying should work, but I'm stumped and don't know what else 
to try next to remedy the situation.

Has anyone seen this before and fixed it?  Is this expected behavior? 
What additional information would help determine an appropriate 

Thanks for any help you can provide.


More information about the R-SIG-Mac mailing list