[R-sig-hpc] Error installing Rmpi over OpenMPI: Cannot find orted

Ei-ji Nakama nakama at ki.rim.or.jp
Fri Nov 7 03:30:30 CET 2014


openmpi of ubuntu / debian is built with --with-tm.
openmpi module (mca_plm_tm.so)  have a soname(libtorque.so.2) , need
solve the symbol of tm_init, tm_spawn, tm_finalize and tm_poll.
I suggest you do  only build torque and maui.
Add /opt/torque/lib to a new file in /etc/ld.so.conf.d/torque.conf and
run ldconfig.
and `apt-get install r-cran-rmpi openmpi-bin'.

I add the following to my cluster for torque,

$ cat torque.profile.sh
# /etc/profile.d/torque.sh
if [ -n "$PBS_ENVIRONMENT" ]; then
    if [ "$PBS_ENVIRONMENT" = "PBS_BATCH" ] ; then
        cd $PBS_O_WORKDIR

When I appointed plm_rsh_agent in the series of openmpi-1.8, I got
segmentation fault.
most recent version (openmpi1.8.4rc) and I'll be much better off.

2014-11-07 3:21 GMT+09:00 Alejandro Gonzalez <aleco.gt at gmail.com>:
> Hello List, this is my first message but I've been using your help for a
> while, thank you.
> I have a cluster of Ubuntu 14.04 machines with OpenMPI and I'm not being
> able to install Rmpi.
> Here are some more specs of my system:
> - I installed from sources Torque 4.2.9 and Maui 3.3.1
> - OpenMPI version is 1.8.2 (I installed this one from source too)
> - R version is 3.0.2 (This was installed with apt-get install)
> When I try to install Rmpi:
> $ sudo R CMD INSTALL Rmpi_0.6-3.tar.gz
> --configure-args="--with-mpi=/opt/openmpi"
> I get the following:
> ---
> * installing to library '/usr/local/lib/R/site-library'
> * installing *source* package 'Rmpi' ...
> checking for gcc... gcc -std=gnu99
> checking whether the C compiler works... yes
> checking for C compiler default output file name... a.out
> checking for suffix of executables...
> checking whether we are cross compiling... no
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc -std=gnu99 accepts -g... yes
> checking for gcc -std=gnu99 option to accept ISO C89... none needed
> Trying to find mpi.h ...
> Found in /opt/openmpi/include
> Trying to find libmpi.so or libmpich.a ...
> Found libmpi in /opt/openmpi/lib
> checking for orted... no
> configure: error: Cannot find orted. Rmpi needs orted to run.
> ERROR: configuration failed for package 'Rmpi'
> * removing '/usr/local/lib/R/site-library/Rmpi'
> ---
> I've read the Rmpi news,
> http://r.789695.n4.nabble.com/Problem-installing-Rmpi-with-Open-MPI-tt4641762.html#none
> and http://www.open-mpi.org/community/lists/devel/2012/04/10840.php and
> then tried to install Rmpi using a new build of OpenMPI, that I configured
> this way:
> $ ./configure --with-tm=/opt/torque --prefix=/opt/openmpi_disable_dlopen
> --disable-dlopen
> But I got the same error (configure: error: Cannot find orted. Rmpi needs
> orted to run.).
> Am I doing something wrong? Do you have a clue on how can I install Rmpi?
> I'd also want to understand more about what does --disable-dlopen mean, why
> it's necessary for Rmpi and what happens when I run other MPI software when
> OpenMPI has been configured with --disable-dlopen. May you share me some
> reading?
> Thanks in advance.
> Alejandro
>         [[alternative HTML version deleted]]
> _______________________________________________
> R-sig-hpc mailing list
> R-sig-hpc at r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-hpc

Best Regards,
Eiji NAKAMA <nakama (a) ki.rim.or.jp>
"\u4e2d\u9593\u6804\u6cbb"  <nakama (a) ki.rim.or.jp>

More information about the R-sig-hpc mailing list