[R-sig-Debian] Configure error: checking if libcurl supports https... no

Rolf Turner r@turner @end|ng |rom @uck|@nd@@c@nz
Sun Aug 29 11:01:43 CEST 2021

On Sun, 29 Aug 2021 10:16:16 +0200
Johannes Ranke <johannes.ranke using jrwb.de> wrote:

> Hi,
> for what it's worth, on a Debian bullseye system, configuring the R
> 4.1.0 tarball works fine:
> $ wget
> https://cran.r-project.org/src/base/R-4/R-4.1.0.tar.gz
> $ tar xf R-4.1.0.tar.gz $ cd R-4.1.0/
> $ ./configure
> ...
> checking if libcurl supports https... yes
> ...
> with libcurl4 and libcurl4-gnutls-dev installed. I believe this
> should also work on Ubuntu.

Hmm.  I may not have had libcurl4 properly installed; tried to install
it (to make sure) and got a message about it having been "manually
installed". (No idea how the <expletive deleted> that happened, but
ne'er mind.) So I removed libcurl4, re-installed it, and tried the
configure step again.  Same result, same error.

> You can try
> $ sudo apt build-dep r-base
> to pull in all build dependencies specified by Dirks R debs, and try
> again.

Thanks for the suggestion.  I did

   sudo apt build-dep r-base

as instructed.

I then noticed that I could not run R --- got a "permission denied"
error.  So I next did:

   sudo apt-get install r-base

After quite a while and after an enourmous amount of incomprehensible
output had been spewed out onto the screen, the command appeared to
succeed and I could run R again.

I then tried the configure step, for building R 4.1.0 from source,
again.  Same result, same error.

Why, in the name of all that's unholy, do these things happen to *me*?


Rolf Turner

P.S. Clearly there must be something broken in my system, but how on
earth do I track down what's wrong?

R. T.

Honorary Research Fellow
Department of Statistics
University of Auckland
Phone: +64-9-373-7599 ext. 88276

More information about the R-SIG-Debian mailing list