[R-pkg-devel] Package fails to build on CRAN Windows server: rtracklayer version too new

Henrik Bengtsson henr|k@bengt@@on @end|ng |rom gm@||@com
Tue Apr 20 03:47:04 CEST 2021

Not that it solves your problem per se, but here's what I think CRAN
only has rtracklayer 1.48.0 installed on WIndows, i.e. why you get
error "namespace 'rtracklayer' 1.48.0 is being loaded, but >= 1.51.5
is required.":

* The current Bioconductor "release" is version 3.12
* As you say, Bioconductor 3.12 provides rtracklayer 1.50.0
* However, if you look at that page, for Windows it only provides
rtracklayer 1.49.5 (this is because rtracklayer never successfully
checked on Bioconductor 3.12)
* Since the minor version component of rtracklayer 1.49.5 is _odd_, it
means it's from a Bioconductor 'devel' branch, i.e. when Bioconductor
3.12 was in devel.
* Thus, the most recent Bioconductor "release" where rtracklayer was
successfully distributed on Windows is Bioconductor 3.11.
* Bioconductor 3.11 provides rtracklayer 1.48.0

Clear as mud?

I suspect you're using Suggest: rtracklayer
(https://github.com/timoast/signac/blob/develop/DESCRIPTION) in your
new version.  If so, that's good.  I also don't think you're doing
anything wrong here.  Instead, I think it's one of your other
Bioconductor dependencies under 'Imports:', or possibly under
'Suggests:', that depend on 'rtracklayer'.  The fact that error says
"namespace 'rtracklayer' 1.48.0 is being loaded, but >= 1.51.5 is
required.", means that one of those Bioconductor dependencies, or
their dependencies, has an explicit 'rtracklayer (>= 1.51.5)' under
either Depends: or Imports:.  My recommendation is that you start
identifying that Bioconductor package, and in what way your 'Signac'
depends on that package.  That will help you decide on what to do


PS. This can happen because Bioconductor allows a package to propagate
to a new "release" branch even if it fails on one of the operating

On Fri, Apr 16, 2021 at 1:59 PM Tim Stuart <tstuart using nygenome.org> wrote:
> Hi all,
> I am trying to submit an update to my package
> (https://cran.r-project.org/package=Signac) to CRAN, but it is
> currently failing to install on the Windows server. I see the
> following installation error: "namespace 'rtracklayer' 1.48.0 is being
> loaded, but >= 1.51.5 is required."
> The current release version for rtracklayer is 1.50.0
> (https://www.bioconductor.org/packages/release/bioc/html/rtracklayer.html).
> My package does not set a version requirement for rtracklayer, so this
> installation error must be caused by having a pre-release version of
> one of my bioconductor dependencies installed on the windows server.
> Does anyone know how I might be able to solve this issue? I have tried
> contacting the CRAN team a few times by reply-all to the CRAN emails,
> but have not had any response from them. This seems like an issue that
> could only be solved by fixing the installation of packages on the
> CRAN Windows server.
> Incoming test results:
> https://win-builder.r-project.org/incoming_pretest/Signac_1.1.2_20210415_225235/
> Thanks,
> Tim
> --
> This message is for the recipient’s use only, and may contain
> confidential, privileged or protected information. Any unauthorized use or
> dissemination of this communication is prohibited. If you received this
> message in error, please immediately notify the sender and destroy all
> copies of this message. The recipient should check this email and any
> attachments for the presence of viruses, as we accept no liability for any
> damage caused by any virus transmitted by this email.
> ______________________________________________
> R-package-devel using r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-package-devel

More information about the R-package-devel mailing list