[R-pkg-devel] Package fails to build on CRAN Windows server: rtracklayer version too new

Tim Stuart t@tu@rt @end|ng |rom nygenome@org
Fri Apr 16 22:45:26 CEST 2021

Hi all,

I am trying to submit an update to my package
(https://cran.r-project.org/package=Signac) to CRAN, but it is
currently failing to install on the Windows server. I see the
following installation error: "namespace 'rtracklayer' 1.48.0 is being
loaded, but >= 1.51.5 is required."

The current release version for rtracklayer is 1.50.0
My package does not set a version requirement for rtracklayer, so this
installation error must be caused by having a pre-release version of
one of my bioconductor dependencies installed on the windows server.

Does anyone know how I might be able to solve this issue? I have tried
contacting the CRAN team a few times by reply-all to the CRAN emails,
but have not had any response from them. This seems like an issue that
could only be solved by fixing the installation of packages on the
CRAN Windows server.

Incoming test results:



This message is for the recipient’s use only, and may contain 
confidential, privileged or protected information. Any unauthorized use or 
dissemination of this communication is prohibited. If you received this 
message in error, please immediately notify the sender and destroy all 
copies of this message. The recipient should check this email and any 
attachments for the presence of viruses, as we accept no liability for any 
damage caused by any virus transmitted by this email.

More information about the R-package-devel mailing list