[R-pkg-devel] CRAN check texi2dvi failure

Paul Gilbert pg||bert902 @end|ng |rom gm@||@com
Sun Jan 10 15:12:17 CET 2021

Thanks Enrico for the great guess, and Georgi for the details.

If I omit the space as seems to be implied in some documentation, changing
   \verb <https://www.bankofcanada.ca/2006/03/working-paper-2006-3> .
   \verb<https://www.bankofcanada.ca/2006/03/working-paper-2006-3> .

then the R CMD check error "\verb ended by end of line" happens on my 
linux machine. I did not try replacing the space with another 
deliminator, which I guess would now be the correct way to use \verb. 
The solution of adding

and changing to

does seem to work. (No "on CRAN" confirmation yet but I have not had the 
immediate pre-test rejection that I got previously.)


On 2021-01-10 8:04 a.m., Georgi Boshnakov wrote:
 > The problem is not in the Warning from the example but from
 > the \verb commands in the references.
 > You use space to delimit the argument of \verb and I was surprised
 > that it worked since TeX ignores spaces after commands.
 > Apparently, this has been an exception for \verb but now this feature
 > is considered a bug and hs been recently fixed, see the atacjexchange
 > question below and the relevant paragraph from LaTeX News. Probably
 > the linux machines have updated their TeX installations.
 > In short, changing the space tp  say  +  delimiter for \verb command 
should fix the issue.
 > Georgi Boshnakov

On 2021-01-09 6:52 p.m., Enrico Schumann wrote:
> When I run R CMD check on my Linux machine [*], I also
> do not get an error.  But here is a guess: The error
> mentions \verb, and the LaTeX manual says that \verb
> should be followed by nonspace character.  But in the
> vignette it is followed by a space.  Maybe using \url
> in the vignette could fix the error?
> kind regards
>      Enrico
> [*] R version 4.0.3 (2020-10-10)
>      Platform: x86_64-pc-linux-gnu (64-bit)
>      Running under: Ubuntu 20.10
> > On Sat, 09 Jan 2021, Paul Gilbert writes:
>> I am trying to debug a problem that is appearing in the
>> linux and Solaris checks, but not Windows or Mac
>> checks, of my package tsfa as reported at
>> https://cran.r-project.org/web/checks/check_results_tsfa.html
>> The problem is with re-building the vignette
>>    ...
>>    this is package 'tsfa' version '2014.10-1'
>>    ...
>>   checking re-building of vignette outputs ... [6s/9s] WARNING
>>   Error(s) in re-building vignettes:
>>    ...
>>      Running 'texi2dvi' on 'Guide.tex' failed.
>>      LaTeX errors:
>>      ! LaTeX Error: \verb ended by end of line.
>>    ...
>> In responding to the threat of removal I have also
>> fixes some long standing warnings about adding imports
>> to the NAMESPACE. The new version builds with --as-cran
>> giving no errors or warnings with both R-devel on
>> win-builder (2021-01-07 r79806) and on my linux machine
>> (R 2021-01-08 r79812 on Linux Mint 19.3 Tricia). When I
>> submit it to CRAN the Windows build is OK but the same
>> error happens at the 'texi2dvi' step in the debian
>> vignette re-build.
>> This seems to happens after an example that correctly
>> has a warning message (about Heywood cases). In my
>> linux build the the warning happens but the message
>> does not appear in the pdf output, so one possibility
>> is that the handling of the warning on the CRAN Unix
>> check machines fails to produce clean tex or suppress
>> output. Another possibility is that my build using
>> --as-cran is different from the actual CRAN build
>> options. For example, my 00check.log shows
>> ...
>> * checking package vignettes in ‘inst/doc’ ... OK
>> * checking re-building of vignette outputs ... OK
>> * checking PDF version of manual ... OK
>> * checking for non-standard things in the check directory ... OK
>> ...
>> so I am not sure if it uses texi2dvi. (I haven't used
>> dvi myself for a long time.)
>> I'm not sure how to debug this when I can't reproduce
>> the error. Suggestions would be appreciated.
>> Paul Gilbert

More information about the R-package-devel mailing list