[R-pkg-devel] More GitHub problems

Spencer Graves @pencer@gr@ve@ @end|ng |rom e||ect|vede|en@e@org
Tue Apr 21 15:30:20 CEST 2020

Hi, Ivan et al:

On 2020-04-21 02:15, Ivan Krylov wrote:
> On Mon, 20 Apr 2020 23:44:43 -0500
> Spencer Graves <spencer.graves using effectivedefense.org> wrote:
>> Is there a way to restore the functionality of a local clone of a
>> GitHub repository after the SSH key it used was replaced?
> Does `git remote -v` in the repo directory show https://github.com/...
> or git using github.com:... or ssh://... URLs?
> Can you add the new SSH key on <https://github.com/settings/keys> and
> check ~/.ssh/config to make sure that it's used when connecting to
> github.com? You can verify that the SSH part of the stack works by
> running `ssh git using github.com`:
> PTY allocation request failed on channel 0
> Hi <username>! You've successfully authenticated, but GitHub does not
> provide shell access.
> Connection to github.com closed.
>>         I have a local clone that previously worked fine but now asks
>> for a password that I don't think I have when I try "git push".
> This sounds like it's using an https:// remote URL, not ssh. But I
> might be mistaken.

You were absolutely correct.  The problem was fixed by copying "url = 
git using github.com:<GitHub_user>/<GitHub_repository>.git" from a repository 
where it worked properly into this one, and it worked.

       Spencer Graves

More information about the R-package-devel mailing list