[R-pkg-devel] Packages required and available but unsuitable versions: Error

Martin Morgan mtmorg@n@b|oc @end|ng |rom gm@||@com
Mon Sep 23 13:44:06 CEST 2019

Probably the easiest 'solution' is to remove the version dependencies, e.g., 'org.Hs.eg.db, org.Mm.eg.db, ...'.

I suspect that the root cause is that the Windows builders do not have the correct version of these packages installed for the version of R in use, perhaps because the version of the package BiocVersion (it should be 3.10.1 in R-devel) is incorrect.

Martin Morgan

On 9/23/19, 6:06 AM, "R-package-devel on behalf of Agarwal, Divyansh" <r-package-devel-bounces using r-project.org on behalf of Divyansh.Agarwal using pennmedicine.upenn.edu> wrote:

    Dear R developers community,
    I’m trying to build and submit an R package to CRAN but keep getting the following error:
    Packages required and available but unsuitable versions:
      'org.Hs.eg.db', 'org.Mm.eg.db', 'org.Ce.eg.db'
    The DESCRIPTION file for my package includes the following:
      R (>= 3.5.0),
      stats (>= 3.5.0),
      MASS (>= 7.3-49),
    Encoding: UTF-8
      nbpMatching (>= 1.5.1),
      crossmatch (>= 1.3-1),
      Matrix (>= 1.2-17),
      org.Hs.eg.db (>= 3.6.0),
      org.Mm.eg.db (>= 3.6.0),
      org.Ce.eg.db (>= 3.6.0),
      Seurat (>= 3.0.0),
      AnnotationDbi (>= 1.42.1)
    The details of the error log are here: <https://win-builder.r-project.org/incoming_pretest/multicross_2.0.0_20190923_044655/>
    I’ve tried a few different things such as specifying an R version under “Depends” or updating the version for the “org.” packages to the latest version (>=3.8) but I haven’t been able to resolve the error and warnings shown in the error log.  I would be really grateful to you if you could kindly advise a potential solution for how to possibly fix this error.
    Thanks a lot in advance!
    	[[alternative HTML version deleted]]
    R-package-devel using r-project.org mailing list

More information about the R-package-devel mailing list