[R-pkg-devel] Packages required and available but unsuitable versions: Error

Agarwal, Divyansh D|vy@n@h@Ag@rw@| @end|ng |rom pennmed|c|ne@upenn@edu
Mon Sep 23 10:44:37 CEST 2019

Dear R developers community,

I’m trying to build and submit an R package to CRAN but keep getting the following error:
Packages required and available but unsuitable versions:
  'org.Hs.eg.db', 'org.Mm.eg.db', 'org.Ce.eg.db'

The DESCRIPTION file for my package includes the following:
  R (>= 3.5.0),
  stats (>= 3.5.0),
  MASS (>= 7.3-49),
Encoding: UTF-8
  nbpMatching (>= 1.5.1),
  crossmatch (>= 1.3-1),
  Matrix (>= 1.2-17),
  org.Hs.eg.db (>= 3.6.0),
  org.Mm.eg.db (>= 3.6.0),
  org.Ce.eg.db (>= 3.6.0),
  Seurat (>= 3.0.0),
  AnnotationDbi (>= 1.42.1)

The details of the error log are here: <https://win-builder.r-project.org/incoming_pretest/multicross_2.0.0_20190923_044655/>

I’ve tried a few different things such as specifying an R version under “Depends” or updating the version for the “org.” packages to the latest version (>=3.8) but I haven’t been able to resolve the error and warnings shown in the error log.  I would be really grateful to you if you could kindly advise a potential solution for how to possibly fix this error.

Thanks a lot in advance!

	[[alternative HTML version deleted]]

More information about the R-package-devel mailing list