[R-pkg-devel] Trying to compile R-3.5.1 with openblas for windows

Erin Hodgess erinm@hodge@@ @ending from gm@il@com
Fri Sep 14 22:14:06 CEST 2018

Hi again!

I checked everything, did "make distribution" and the same thing occurred.

d:/Rtools/mingw_64/bin/ar -rucs ../SuiteSparse_config.a SuiteSparse_config.o
D:\Rtools\mingw_64\bin\nm.exe: 'sublibs': No such file
d:/Rtools/mingw_64/bin/gcc -shared -s -static-libgcc -o Matrix.dll tmp.def
CHMfactor.o Csparse.o TMatrix_as.o Tsparse.o init.o Mutils.o chm_common.o
cs.o cs_utils.o dense.o dgCMatrix.o dgTMatrix.o dgeMatrix.o dpoMatrix.o
dppMatrix.o dsCMatrix.o dsyMatrix.o dspMatrix.o dtCMatrix.o dtTMatrix.o
dtrMatrix.o dtpMatrix.o factorizations.o ldense.o lgCMatrix.o sparseQR.o
abIndex.o -LD:/erinm/R-3.5.1/bin/x64 -lRlapack -LD:/erinm/R-3.5.1/bin/x64
-lRblas -LD:/erinm/R-3.5.1/extsoft/lib/x64 -LD:/erinm/R-3.5.1/extsoft/lib
-LD:/erinm/R-3.5.1/bin/x64 -lR
CHMfactor.o:CHMfactor.c:(.text+0x3b): undefined reference to
CHMfactor.o:CHMfactor.c:(.text+0x7b): undefined reference to
CHMfactor.o:CHMfactor.c:(.text+0x92): undefined reference to
CHMfactor.o:CHMfactor.c:(.text+0xa5): undefined reference to
CHMfactor.o:CHMfactor.c:(.text+0x18e): undefined reference to
CHMfactor.o:CHMfactor.c:(.text+0x267): undefined reference to
CHMfactor.o:CHMfactor.c:(.text+0x27e): undefined reference to
CHMfactor.o:CHMfactor.c:(.text+0x396): undefined reference to
CHMfactor.o:CHMfactor.c:(.text+0x620): undefined reference to
CHMfactor.o:CHMfactor.c:(.text+0x658): undefined reference to
CHMfactor.o:CHMfactor.c:(.text+0x720): undefined reference to
CHMfactor.o:CHMfactor.c:(.text+0x87b): undefined reference to
CHMfactor.o:CHMfactor.c:(.text+0x8c3): undefined reference to
Csparse.o:Csparse.c:(.text+0x9f1): undefined reference to
Csparse.o:Csparse.c:(.text+0xcd6): undefined reference to `cholmod_speye'
Csparse.o:Csparse.c:(.text+0xd21): undefined reference to `cholmod_add'
Csparse.o:Csparse.c:(.text+0xd31): undefined reference to
Csparse.o:Csparse.c:(.text+0xd3d): undefined reference to
Csparse.o:Csparse.c:(.text+0xd4c): undefined reference to
Csparse.o:Csparse.c:(.text+0xdf9): undefined reference to `cholmod_copy'

Does this look familiar, please?


Erin Hodgess, PhD
mailto: erinm.hodgess using gmail.com

On Fri, Sep 14, 2018 at 1:13 PM Avraham Adler <avraham.adler using gmail.com>

> Try following the directions here. They have worked for me for years.
> Please see the comments too.
> https://www.avrahamadler.com/r-tips/build-openblas-for-windows-r64/
> Hope that helps,
> Avi
> On Fri, Sep 14, 2018 at 2:34 PM Erin Hodgess <erinm.hodgess using gmail.com>
> wrote:
>> Hello!
>> I'm building a package that needs Openblas for matrix manipulation speed
>> up.
>> I built Openblas on Windows 10.  I updated the MkRules.local,
>> src/extra/blas/Makefile.win, etc.  Things are working with "make all".
>> However, when I run "make recommended", I have trouble with the Matrix
>> package build.  The components of the Cholesky all appear as unreferenced.
>> Has anyone else run into this, please?  I'm working with R-3.5.1 source.
>> Thanks,
>> Erin
>> Erin Hodgess, PhD
>> mailto: erinm.hodgess using gmail.com
>>         [[alternative HTML version deleted]]
>> ______________________________________________
>> R-package-devel using r-project.org mailing list
>> https://stat.ethz.ch/mailman/listinfo/r-package-devel
> --
> Sent from Gmail Mobile

	[[alternative HTML version deleted]]

More information about the R-package-devel mailing list