[R-pkg-devel] Warning "Dependence on R version '3.3.3' not with patchlevel 0"
pdalgd at gmail.com
Wed Jan 3 15:05:55 CET 2018
Yep. Bear in mind that many system-wide installation, e.g. in universities, are of .0 or .1 releases and upgraded yearly. If we end up with packages depending on packages depending on a later version, bad things can happen (and _did_ happen in the 3.2.* series). For the same reason, we have become very careful not to add features into R-patched,so it should be rather unlikely that packages that work with x.y.z do not also work with x.y.0.
> On 3 Jan 2018, at 14:33 , Uwe Ligges <ligges at statistik.tu-dortmund.de> wrote:
> On 03.01.2018 13:59, Hockemeyer, Cord (cord.hockemeyer at uni-graz.at) wrote:
>> Hi everybody,
>> on submitting a new package I got a rejection because of the above warning in the CRAN-check. I guess it is because of the "Depends" entry "R (>= 3.3.3)" in the DESCRIPTION file but I have no idea how to do this otherwise. Any hel�p would be highly appreciated.
> If sufficient, use R (>= 3.3.0), otherwise R (>= 3.4.0): If you rely on a specific patchlevel, binary repositories are inconsistant on CRAN and typically you should be able to rely on a x.y.0 release.
> Uwe Ligges
>> Best regards,
>> Cord Hockemeyer
>> Institut f�r Psychologie, Universit�t Graz
>> Tel.: +43 316 380 8531
>> [[alternative HTML version deleted]]
>> R-package-devel at r-project.org mailing list
> R-package-devel at r-project.org mailing list
Peter Dalgaard, Professor,
Center for Statistics, Copenhagen Business School
Solbjerg Plads 3, 2000 Frederiksberg, Denmark
Office: A 4.23
Email: pd.mes at cbs.dk Priv: PDalgd at gmail.com
More information about the R-package-devel