[R-pkg-devel] Exited with status -1073741819.

Martin Maechler maechler at stat.math.ethz.ch
Wed Nov 29 17:07:09 CET 2017

>>>>> Rampal S Etienne <rampaletienne at gmail.com>
>>>>>     on Wed, 29 Nov 2017 14:22:54 +0100 writes:

    > Dear Marc, Martin, Dason,
    > I agree that the status number is not very informative, but neither is:
    > "Package does not build". The point is that I have no clue what is going
    > on, and was just hoping that someone might have seen the exit status
    > number before.

    > I have done a clean install as suggested but still it won't work with
    > R-devel, but it does with R-3.4.2.

    > I don't see how my setup is special in any way. It never caused me any
    > problems until installing the latest R-devel. What are the changes in
    > the latest R-devel that affect the building of packages?

1000s of packages are built every day with R-devel, notably on
the machines that produce the CRAN checks, but also in several
if not many other places.

Consequently, it must be *your* problem, notably as your package
does build flawlessly on 5 different CRAN check machines running R-devel.

But of course, the purpose of *this* list (not of R-devel!) is
to help you with this problem,
hence back to what you wrote above:

"Package does not build"  is actually  more useful than a status
   number that looks random (and/or from a large integer overflow ..).

To me it would mean the package does not even build and
therefore *check*ing the package did not even properly start.

As next step (in solving the problem) you should probably learn
to either debug the devtools which you are probably using
[otherwise you would give us more information !],
or---even more useful in the long run---learn to build a package
in the shell (aka "terminal") instead of inside RStudio, because then,
using 'Rcmd build <pkg>' would almost surely give you more clues
than just "does not build".

    > On 29-11-2017 11:16, Martin Maechler wrote:
    >>>>>>> Rampal S Etienne <rampaletienne at gmail.com>
    >>>>>>> on Wed, 29 Nov 2017 09:19:29 +0100 writes:
    >> > Dear Dason,
    >> > I don't get this error, but it crashes anyway. 
    >> and you don't show what "crashes" means here.
    >> (and yes, Dason is right: The RStudio status number in the
    >> 'Subject' is not really useful)
    >> > I've that if I use the
    >> > stable version of R (3.4.2) I do NOT get the error anymore, so I assume
    >> > there is something wrong with the current R-devel.
    >> > Regards,
    >> > Rampal Etienne
    >> OTOH, the CRAN checks of your package run without any problem
    >> with all 5 versions of R-devel there :
    >> https://cran.r-project.org/web/checks/check_results_SADISA.html
    >> so it may rather be something specific to your setup ??
    >> Martin Maechler
    >> > On 29-11-2017 0:36, Dason Kurkiewicz wrote:
    >> >> Do you get the same error if you try to build on the command line
    >> >> outside of RStudio?
    >> >> 
    >> >> On Nov 28, 2017 3:51 PM, "Rampal Etienne" <rampaletienne at gmail.com
    >> >> <mailto:rampaletienne at gmail.com>> wrote:
    >> >> 
    >> >> Dear all,
    >> >> 
    >> >> I updated RStudio, Rtools and R-devel, and then I tried to build a
    >> >> package in RStudio that I had been able to build before without
    >> >> any problems. But now I got the following error:
    >> >> 
    >> >> Updating SADISA documentatiob
    >> >> Loading SADISA
    >> >> Exited with status -1073741819.
    >> >> 
    >> >> That's all. What is this exit status? I can still build other
    >> >> packages, so it does not happen all the time. I can use "Load all"
    >> >> and all functions sseem to work fine.
    >> >> 
    >> >> Any suggestions?
    >> >> 
    >> >> Kind regards, Rampal Etienne

More information about the R-package-devel mailing list