[R-pkg-devel] Exited with status -1073741819.

Marc Schwartz marc_schwartz at me.com
Wed Nov 29 16:40:43 CET 2017


One additional thought here.

Since you reference RTools in your initial post, I presume that this is occurring on Windows, though not sure which version.

Have you tried to build the package using the WinBuilder site provided by Uwe?

If not, go here:


and request a build of the package using R-Devel.

See if any warnings/errors are picked up there. If not, then that would seem to reinforce the notion that there is something going on locally on your system.

Also, unless I missed it, you did not indicate which version of R-Devel you are running or where you obtained it. Did you get it from:





> On Nov 29, 2017, at 8:22 AM, Rampal S. Etienne <rampaletienne at gmail.com> wrote:
> Dear Marc, Martin, Dason,
> I agree that the status number is not very informative, but neither is:
> "Package does not build". The point is that I have no clue what is going
> on, and was just hoping that someone might have seen the exit status
> number before.
> I have done a clean install as suggested but still it won't work with
> R-devel, but it does with R-3.4.2.
> I don't see how my setup is special in any way. It never caused me any
> problems until installing the latest R-devel. What are the changes in
> the latest R-devel that affect the building of packages?
> Cheers, Rampal
> On 29-11-2017 11:16, Martin Maechler wrote:
>>>>>>> Rampal S Etienne <rampaletienne at gmail.com>
>>>>>>>    on Wed, 29 Nov 2017 09:19:29 +0100 writes:
>>> Dear Dason,
>>> I don't get this error, but it crashes anyway. 
>> and you don't show what "crashes" means here.
>> (and yes, Dason is right: The RStudio status number in the
>> 'Subject' is not really useful)
>>> I've that if I use the
>>> stable version of R (3.4.2) I do NOT get the error anymore, so I assume
>>> there is something wrong with the current R-devel.
>>> Regards,
>>> Rampal Etienne
>> OTOH, the CRAN checks of your package run without any problem
>> with all 5 versions of R-devel there :
>>  https://cran.r-project.org/web/checks/check_results_SADISA.html
>> so it may rather be something specific to your setup ??
>> Martin Maechler
>>> On 29-11-2017 0:36, Dason Kurkiewicz wrote:
>>>> Do you get the same error if you try to build on the command line
>>>> outside of RStudio?
>>>> On Nov 28, 2017 3:51 PM, "Rampal Etienne" <rampaletienne at gmail.com
>>>> <mailto:rampaletienne at gmail.com>> wrote:
>>>> Dear all,
>>>> I updated RStudio, Rtools and R-devel, and then I tried to build a
>>>> package in RStudio that I had been able to build before without
>>>> any problems. But now I got the following error:
>>>> Updating SADISA documentatiob
>>>> Loading SADISA
>>>> Exited with status -1073741819.
>>>> That's all. What is this exit status? I can still build other
>>>> packages, so it does not happen all the time. I can use "Load all"
>>>> and all functions sseem to work fine.
>>>> Any suggestions?
>>>> Kind regards, Rampal Etienne

More information about the R-package-devel mailing list