[R] Redhat Linux Install

Ryan Garner ryan.steven.garner at gmail.com
Fri Mar 5 22:45:34 CET 2010

I just installed R on Redhat Linux at work for the first time and have two

1. I tried to install R to have png and cairo capabilities and was
unsuccessful. Before running make, I ran ./configure --with-libpng=yes
--with-x=no --with-cairo=yes --with-readline-yes . R installed fine, but
when I run R and type capabilities()
> capabilities()
     jpeg     png        tiff       tcltk     X11       aqua       http/ftp 
    TRUE     TRUE     TRUE     TRUE    FALSE    FALSE     TRUE      TRUE 
  l  ibxml    fifo         cledit     iconv     NLS      profmem    cairo 
    TRUE    FALSE     TRUE     TRUE     TRUE     TRUE        FALSE 

Why are png and cairo still FALSE?

2. I would also like to have X11 enabled. From reading the message board,
the consesus seems to be to install xorg-dev. I'm unable to do this because
I don't have root or super user priveleges. But if I'm able to log into my
work servers with PuTTY and Xming and run xemacs or xvim, does this mean
that X11 is already installed somewhere? If so, how do I specify this when
doing ./configure?

View this message in context: http://n4.nabble.com/Redhat-Linux-Install-tp1580181p1580181.html
Sent from the R help mailing list archive at Nabble.com.

More information about the R-help mailing list