[R] Redhat Linux Install

Marc Schwartz marc_schwartz at me.com
Sat Mar 6 14:54:34 CET 2010

On Mar 5, 2010, at 3:45 PM, Ryan Garner wrote:

> I just installed R on Redhat Linux at work for the first time and have two
> questions.
> 1. I tried to install R to have png and cairo capabilities and was
> unsuccessful. Before running make, I ran ./configure --with-libpng=yes
> --with-x=no --with-cairo=yes --with-readline-yes . R installed fine, but
> when I run R and type capabilities()
>> capabilities()
>     jpeg     png        tiff       tcltk     X11       aqua       http/ftp 
> sockets 
>    TRUE     TRUE     TRUE     TRUE    FALSE    FALSE     TRUE      TRUE 
>  l  ibxml    fifo         cledit     iconv     NLS      profmem    cairo 
>    TRUE    FALSE     TRUE     TRUE     TRUE     TRUE        FALSE 
> Why are png and cairo still FALSE?
> 2. I would also like to have X11 enabled. From reading the message board,
> the consesus seems to be to install xorg-dev. I'm unable to do this because
> I don't have root or super user priveleges. But if I'm able to log into my
> work servers with PuTTY and Xming and run xemacs or xvim, does this mean
> that X11 is already installed somewhere? If so, how do I specify this when
> doing ./configure?

There is conflicting information here.

You specified --with-x=no, yet you want X. You indicate that you "installed R", yet you do not have root access.

In order to compile R from source and have the functionality that you seem to want, you will need either have root access to install the required libraries or have the SysAdmin do so. In order to install R using the defaults, you need to have root access or have your SysAdmin do so. 

The required libraries are the 'dev' or development versions of the RPMs for each of the components such as libpng, cairo, readline and X. These contain the header files (.h) that are required to compile R from source and support these features. These issues are described in the R Installation and Administration manual:


The easier option would be to have the SysAdmin simply use the available RPMs for R rather than compiling from source. I presume that by Red Hat Linux, you mean RHEL. You can point your SysAdmin to the EPEL (http://fedoraproject.org/wiki/EPEL) which provides pre-built RPMs for R, installable by using 'yum'.

If you can use ssh to login to the server using PuTTY and that supports X as you indicate, then it means that the server has been configured to support 'X forwarding' and that your ssh login is using the '-X' option to request it on your end of the connection. This means that the server supports X, but may or may not have the X related development RPMs installed, which as I note, are required to compile R from source and support X. Xming, on the other hand, I believe provides its own X server implementation, which potentially brings other issues into play. I have not used it, so would defer to others on the details.


Marc Schwartz

More information about the R-help mailing list