[ESS] Setting paths to R versions in different directories

Vitalie Spinu spinuvit at gmail.com
Fri Oct 17 03:45:28 CEST 2014

Theoretically, it should be enough to have a sim-link of your R binaries
into your bin path. This seems to work very well for
Martin. Unfortunately it never worked for me. I have multiple R
installed and simlinked but I don't see any of them.

I had in plan to check what is going on for ages and never got down to
it as it never bothered me that much.

As a quick workaround you can have:
   (defun R-x.y.z ()
     (let ((inferior-R-program-name "path/to/xyz/R"))


 >>> Brian Hobbs on Thu, 16 Oct 2014 15:51:56 -0400 wrote:

 > Hello all,
 > I am trying to customize my ESS so that I can easily refer to older version
 > of R as needed to use packages that are not compatible with the most up to
 > date R version.

 > I am currently running GNU Emacs 24.1.1 with ESS Version 14.09. I use Emacs
 > and ESS on a linux server where the main R version is kept at /local/bin/R
 > which refers to version 3.1.1 via a symbolic link.

 > When I am in Emacs and type M-x R-[tab] I do not see any R versions come up
 > in my completions list. My current completions list is:
 > Possible completions are:
 > R-fix-T-F                 R-initialize-on-start     R-mode
 > R-newest                  R-site-search             R-transcript-mode

 > I had seen that you could set R-devel in older versions of ESS, but I do
 > not see that as a variable now.

 > I have explored the variable (ess-r-versions-created) and found its value
 > to be nil. I then looked at (ess-rterm-version-paths) and also found that
 > to have a value of nil.

 > I then tried to edit my .emacs file to set the (ess-rterm-version-paths)
 > variable to the path to R version 3.0.1 located in my bin with the
 > following addition to my .emacs file under (custom-set-variables

 > '(ess-rterm-version-paths "/udd/user/bin/R-3.0.1")

 > However, this only updated the ess-rterm-version-paths variable and did not
 > update the ess-r-versions-created variable. So, with this change I could
 > not use M-x R-3.0.1.

 > I also tried running M-x ess-find-rterm, but this command does not exist
 > for me.

 > Simply put, I want to find a way to customize ESS so that by default I use
 > the most updated R version on our server located at /local/bin/R with an
 > option to easily choose an older version of R local in my personal
 > directory at /udd/user/bin/R-3.0.1.

 > I would appreciate any help or advice that anyone could offer.

 > Thank you,
 > Brian

 > 	[[alternative HTML version deleted]]

 > ______________________________________________
 > ESS-help at r-project.org mailing list
 > https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list