[ESS] Setting paths to R versions in different directories

Brian Hobbs rebdh at channing.harvard.edu
Thu Oct 16 21:51:56 CEST 2014

Hello all,

I am trying to customize my ESS so that I can easily refer to older version
of R as needed to use packages that are not compatible with the most up to
date R version.

I am currently running GNU Emacs 24.1.1 with ESS Version 14.09. I use Emacs
and ESS on a linux server where the main R version is kept at /local/bin/R
which refers to version 3.1.1 via a symbolic link.

When I am in Emacs and type M-x R-[tab] I do not see any R versions come up
in my completions list. My current completions list is:
Possible completions are:
R-fix-T-F                 R-initialize-on-start     R-mode
R-newest                  R-site-search             R-transcript-mode

I had seen that you could set R-devel in older versions of ESS, but I do
not see that as a variable now.

I have explored the variable (ess-r-versions-created) and found its value
to be nil. I then looked at (ess-rterm-version-paths) and also found that
to have a value of nil.

I then tried to edit my .emacs file to set the (ess-rterm-version-paths)
variable to the path to R version 3.0.1 located in my bin with the
following addition to my .emacs file under (custom-set-variables

'(ess-rterm-version-paths "/udd/user/bin/R-3.0.1")

However, this only updated the ess-rterm-version-paths variable and did not
update the ess-r-versions-created variable. So, with this change I could
not use M-x R-3.0.1.

I also tried running M-x ess-find-rterm, but this command does not exist
for me.

Simply put, I want to find a way to customize ESS so that by default I use
the most updated R version on our server located at /local/bin/R with an
option to easily choose an older version of R local in my personal
directory at /udd/user/bin/R-3.0.1.

I would appreciate any help or advice that anyone could offer.

Thank you,

	[[alternative HTML version deleted]]

More information about the ESS-help mailing list