[ESS] Completion + Help (was John Fox init.el in mac OS)

Tiago R Magalhães tiago17 at gmail.com
Mon Oct 8 19:30:26 CEST 2007

Dear John, and other members of the mailing list

I tried to have your init.el file working, but just couldn't do it. 
Meanwhile, looking for short-cuts, I have been able to compile a list of 
short cuts.

Two problems I have not solved are:

(1) Completion,
which reports "last thing matched was not a buffer".

(2) C-c C-v does not opens help
and the help file are "messed up",

which actually when I copied it to this email it became (to my surprise…):

I have a MacBook Pro, Xemacs 21.4 (patch15); Ess 5.2.10

Any thoughs on this?

Again, thanks for the help of the mailing list

John Fox wrote:
> Dear Tiago,
> This init file was originally created for XEmacs under Windows, and it
> hasn't been updated for a long time. I originally created the configuration
> for relatively naïve users, who are now have access to Tinn-R. In any event,
> I don't have a Mac on which to test the file.
> I'm sorry that I can't be of more help.
> John
> --------------------------------
> John Fox, Professor
> Department of Sociology
> McMaster University
> Hamilton, Ontario
> Canada L8S 4M4
> 905-525-9140x23604
> http://socserv.mcmaster.ca/jfox 
> -------------------------------- 
>> -----Original Message-----
>> From: ess-help-bounces at stat.math.ethz.ch 
>> [mailto:ess-help-bounces at stat.math.ethz.ch] On Behalf Of 
>> Tiago R Magalhães
>> Sent: Monday, October 01, 2007 4:38 AM
>> To: ess-help at stat.math.ethz.ch
>> Subject: [ESS] John Fox init.el in mac OS (basic question)
>> Dear members of ESS list,
>> I am trying to use the configurations from John Fox, from his 
>> init.el file.
>> The issue is that I have a macintosh (MacBook Pro with 
>> 10.4.10 installed).
>> Xemacs is running. R is also running. Ess loads correctly.
>> When the xemacs opens I see "R fontifying", which goes for a 
>> long time and at the end I get the error message:
>> (1) (initialization/error) An error has occurred while loading
>> /Users/tiago/.xemacs/init.el:
>> Timeout waiting for prompt. Check inferior-ess-prompt or 
>> ess-loop-timeout.
>> If anyone has any advice, thank you very much.
>> I have tried to check the ESS mailing list, but couldn't find 
>> anything about it.
>> Best,
>> Tiago M
>> ______________________________________________
>> ESS-help at stat.math.ethz.ch mailing list
>> https://stat.ethz.ch/mailman/listinfo/ess-help


More information about the ESS-help mailing list