[ESS] Completion + Help (was John Fox init.el in mac OS)

Martin Maechler maechler at stat.math.ethz.ch
Wed Oct 10 19:59:17 CEST 2007

Dear Tiago,

>>>>> "TRM" == Tiago R Magalhães <tiago17 at gmail.com>
>>>>>     on Mon, 08 Oct 2007 18:30:26 +0100 writes:

    TRM> Dear John, and other members of the mailing list I
    TRM> tried to have your init.el file working, but just
    TRM> couldn't do it.  Meanwhile, looking for short-cuts, I
    TRM> have been able to compile a list of short cuts.

I understand John (cited at the end) as saying that this
init.el  possibly was not current at all, particularly not for MacOS.

We (ESS core) would appreciate if you try to follow the ESS
 (Use http://ESS.r-project.org/  if you can't use the docu that
  comes with ESS)
on installation, which has no 'init.el' and only adds one line
to your ~/.emacs or ~/.xemacs.... {whatever the equivalent there is}

    TRM> Two problems I have not solved are:

    TRM> (1) Completion, which reports "last thing matched was
    TRM> not a buffer".

    TRM> (2) C-c C-v does not opens help and the help file are
    TRM> "messed up", e.g.:

    TRM> _^HE_^Hx_H^a_Hm_Hp which actually when I copied it to
    TRM> this email it became (to my surprise…):
    TRM> _E_x_a_m_p_l_e_s:

    TRM> I have a MacBook Pro, Xemacs 21.4 (patch15); Ess 5.2.10

ESS 5.2.10 is  *VERY* outdated; particularly since we (ESS core)
have been working around several Xemacs infelicities.

Can you try with the current version of ESS (5.3.6)
and then report problems ?

    TRM> Any thoughs on this?

    TRM> Again, thanks for the help of the mailing list

    TRM> John Fox wrote:
    >> Dear Tiago,
    >> This init file was originally created for XEmacs under
    >> Windows, and it hasn't been updated for a long time. I
    >> originally created the configuration for relatively naïve
    >> users, who are now have access to Tinn-R. In any event, I
    >> don't have a Mac on which to test the file.
    >> I'm sorry that I can't be of more help.
    >> John
    >> --------------------------------
    >> John Fox, Professor Department of Sociology McMaster
    >> University Hamilton, Ontario Canada L8S 4M4
    >> 905-525-9140x23604 http://socserv.mcmaster.ca/jfox
    >> -------------------------------- 
    >>> -----Original Message----- From:
    >>> ess-help-bounces at stat.math.ethz.ch
    >>> [mailto:ess-help-bounces at stat.math.ethz.ch] On Behalf Of
    >>> Tiago R Magalhães Sent: Monday, October 01, 2007 4:38 AM
    >>> To: ess-help at stat.math.ethz.ch Subject: [ESS] John Fox
    >>> init.el in mac OS (basic question)
    >>> Dear members of ESS list,
    >>> I am trying to use the configurations from John Fox,
    >>> from his init.el file.
    >>> The issue is that I have a macintosh (MacBook Pro with
    >>> 10.4.10 installed).  Xemacs is running. R is also
    >>> running. Ess loads correctly.
    >>> When the xemacs opens I see "R fontifying", which goes
    >>> for a long time and at the end I get the error message:
    >>> (1) (initialization/error) An error has occurred while
    >>> loading /Users/tiago/.xemacs/init.el:
    >>> Timeout waiting for prompt. Check inferior-ess-prompt or
    >>> ess-loop-timeout.
    >>> If anyone has any advice, thank you very much.  I have
    >>> tried to check the ESS mailing list, but couldn't find
    >>> anything about it.
    >>> Best, Tiago M
    >>> ______________________________________________
    >>> ESS-help at stat.math.ethz.ch mailing list
    >>> https://stat.ethz.ch/mailman/listinfo/ess-help


    TRM> ______________________________________________
    TRM> ESS-help at stat.math.ethz.ch mailing list
    TRM> https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list