[ESS] file name completion again

david whiting david.r.whiting at gmail.com
Wed Aug 31 22:57:58 CEST 2005

Hmmmm, ok. I reinstalled xemacs and got ESS out of the subversion
repository. I then started xemacs with:

xemacs --vanilla &

and in the *scratch* buffer I loaded ess-site.el. No problems. I then started R:

M-x R 

and selected a working directory that has a subdirectory with an R
data file. In ESS/R I then did:


and pressed tab to complete the file name and got the "last thing
matched was not a buffer" message.

Oooooh, this is interesting . . . xemacs has a right mouse menu (you
learn something new every day). OK, with the pop-up menu if I click on
"Complete -> Complete File name" it works okay. So, the response is
different depending on whether I use TAB or the mouse.  Does that

When I installed xemacs I just selected xemacs and let synaptic choose
what else to install. It installed:

xemacs21 (21.4.17-1)
xemacs21-basesupport-el (2004.08.18-2)
xemacs21-bin (21.4.17-1)
xemacs21-mule (21.4.17-1)
xemacs21-mulesupport  (2004.08.18-2)
xemacs21-support (21.4.17-1)

R 2.1.1
> version
platform i686-pc-linux-gnu
arch     i686             
os       linux-gnu        
system   i686, linux-gnu  
major    2                
minor    1.1              
year     2005             
month    06               
day      20               
language R                

ESS from subversion so it should be the same as what you have? I
installed ESS in ~/tmp/ess.

OS: Ubuntu 5.04

Anything else we can compare?


On 31/08/05, Martin Maechler <maechler at stat.math.ethz.ch> wrote:
> >>>>> "david" == david whiting <david.r.whiting at gmail.com>
> >>>>>     on Wed, 31 Aug 2005 19:05:45 +0100 writes:
>     david> On 31/08/05, Martin Maechler
>     david> <maechler at stat.math.ethz.ch> wrote: [...]
>     >> That "last thing matched was not a buffer" sounds pretty
>     >> nasty, but I've never seen it.  It must be
>     >> Xemacs-specific somehow.
>     >>
>     >> Any Xemacs users who can help ??
>     >>
>     david> I can confirm the behaviour. I have just installed
>     david> xemacs (version 21.4 patch 17 on ubuntu 5.04),
>     david> checked ess out of subversion and got the same
>     david> message.
>     david> As to what it means . . . sorry I can't help. I'm
>     david> going back to real emacs :)
> Thank you, David.
> Still,  I've now also installed xemacs21 on my ubuntu system at
> home, and while it gives strange startup messages and warnings,
> ess 5.2.9 seems to work quite nicely.
> Both with my usual (non trivial) initializations (.emacs or .xemacs/init.el)
> and used as
>     xemacs --vanilla
> and then in the *scratch* buffer
>     (load "..../ess/lisp/ess-site")
> and everything worked (M-x R ; editing *.R files ..)
> as long as I tried (not too long).
> Now what is the difference between your setup and mine?
> Have you tried  xemacs --vanilla  + manual loading of ess-site ?
> Regards,
> Martin

David Whiting

More information about the ESS-help mailing list