[ESS] file name completion again

Martin Maechler maechler at stat.math.ethz.ch
Wed Aug 31 21:54:16 CEST 2005

>>>>> "david" == david whiting <david.r.whiting at gmail.com>
>>>>>     on Wed, 31 Aug 2005 19:05:45 +0100 writes:

    david> On 31/08/05, Martin Maechler
    david> <maechler at stat.math.ethz.ch> wrote: [...]

    >> That "last thing matched was not a buffer" sounds pretty
    >> nasty, but I've never seen it.  It must be
    >> Xemacs-specific somehow.
    >> Any Xemacs users who can help ??

    david> I can confirm the behaviour. I have just installed
    david> xemacs (version 21.4 patch 17 on ubuntu 5.04),
    david> checked ess out of subversion and got the same
    david> message.

    david> As to what it means . . . sorry I can't help. I'm
    david> going back to real emacs :)

Thank you, David.

Still,  I've now also installed xemacs21 on my ubuntu system at
home, and while it gives strange startup messages and warnings,
ess 5.2.9 seems to work quite nicely.
Both with my usual (non trivial) initializations (.emacs or .xemacs/init.el)
and used as
    xemacs --vanilla
and then in the *scratch* buffer
    (load "..../ess/lisp/ess-site")

and everything worked (M-x R ; editing *.R files ..)
as long as I tried (not too long).

Now what is the difference between your setup and mine?
Have you tried  xemacs --vanilla  + manual loading of ess-site ?


More information about the ESS-help mailing list