[BioC] Problem with hgu133plus2.db package

Morten Hansen mhansen at sund.ku.dk
Tue Jun 16 12:07:27 CEST 2009

I have a problem with the hgu133plus2.db package.

Usually when I want to use the data from hgu133plus2GO2PROBE , I do the following:

> a <- as.list( hgu133plus2GO2PROBE )

Works fine.

Now I am making a package and need to do the same. When running a function inside the package that does the same as above I get the following error:

Error in as.list.default(hgu133plus2GO2PROBE) : 
  no method for coercing this S4 class to a vector

I also tried using mappedkeys() as explained in the example in help, but I get the same error.

I have tested it on a clean R and Bioconductor installation.

Any suggestions?

My sessionInfo():
> sessionInfo()
R version 2.9.0 (2009-04-17) 


attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
 [1] icmmUtils_1.0.0       biomaRt_2.0.0         hgu133plus2.db_2.2.11 annotate_1.22.0       annaffy_1.16.0        KEGG.db_2.2.11       
 [7] GO.db_2.2.11          RSQLite_0.7-1         DBI_0.2-4             AnnotationDbi_1.6.0   Biobase_2.4.1        

loaded via a namespace (and not attached):
[1] RCurl_0.98-1 XML_2.5-1    xtable_1.5-5

Br - Morten Hansen

More information about the Bioconductor mailing list