[BioC] Problems loading biomaRt and XML

Jordi Altirriba Gutiérrez altirriba at hotmail.com
Fri Jun 23 15:20:46 CEST 2006

Dear Seth,
Thanks for your answer.

>What version of the XML package did you download?  Perhaps try one
>more time with biocLite:
>  source("http://bioconductor.org/biocLite.R")
>  biocLite("XML")
>  library("XML")
>I'm guessing that somehow you ended up with a bad/old version of the
>XML package, but am not sure.

The version of XML is 0.99-7.


I've tried to obtain it from CRAN, from the Madrid and the London mirror, 
but I am obtaining the same results:
trying the  URL 
trying the URL 
package 'XML' successfully unpacked and MD5 sums checked (in both cases)

>library (biomaRt) (or library (XML))

The same error described below.


I have used BioCLite, as you suggested, which obtains XML from Omegahat, 

Running getBioC version 0.1.6 with R version 2.3.1
Running biocinstall version 1.8.4 with R version 2.3.1
Your version of R requires version 1.8 of Bioconductor.
trying the URL 
Content type 'application/zip' length 1323552 bytes
URL opened
downloaded 1292Kb

package 'XML' successfully unpacked and MD5 sums checked

The downloaded packages are in
        C:\Documents and Settings\BIO SANTANDER\Configuración 
updating HTML package descriptions

The same error described below.


Any other suggestion?

Many thanks for your suggestions and time!

Yours sincerely,

Jordi Altirriba
PhD student
Hospital Clinic, Barcelona, Spain

>Jordi Altirriba Gutiérrez <altirriba at hotmail.com> writes:
>>After this I install XML (without any problems) and I re-load biomaRt, but 
>>an error message appears in a new window (I am translating it, as the 
>>messages are in Spainsh):
>>The entrance point of _htmlDefaultSAXHandler procedure can.t be found in 
>>the library of dynamic links libxml2.dll
>>Moreover in the R window appears:
>>Loading required package: XML
>>Error in dyn.load(x, as.logical(local), as.logical(now)) :
>>         impossible to load the shared library  
>>   LoadLibrary failure:  The specified process was no found.
>>Error: .onLoad failed in 'loadNamespace' for 'XML'
>>Error: package 'XML' could not be loaded

More information about the Bioconductor mailing list