[BioC] iffail argument in mget of mas5, rma

James MacDonald jmacdon at med.umich.edu
Tue May 18 20:18:08 CEST 2004

You should upgrade to affy 1.4.30, which doesn't have this bug.



James W. MacDonald
Affymetrix and cDNA Microarray Core
University of Michigan Cancer Center
1500 E. Medical Center Drive
7410 CCGC
Ann Arbor MI 48109

>>> Adaikalavan Ramasamy <ramasamy at cancer.org.uk> 05/18/04 01:29PM >>>
I am using R.1.9.0 upgraded to affy 1.4.29, Biobase 1.4.14. I get the
following error below with rma() and mas5() functions and tried to
figure out what is happening all afternoon. I tried it with a couple
datasets with the same results. Can anyone help ?

Thank you, Adai.

> library(affy)
Welcome to Bioconductor
         Vignettes contain introductory material.  To view,
         simply type: openVignette()
         For details on reading vignettes, see
         the openVignette help page.
> library(gcrma)
> data <- ReadAffy()
> data
AffyBatch object
size of arrays=536x536 features (134681 kb)
cdf=Hu6800 (7129 affyids)
number of samples=60
number of genes=7129
> print(date())
[1] "Tue May 18 18:16:42 2004"
> data.rma <- rma( data )
Error in mget(genenames, pos, envir, iffail = NA) :
        unused argument(s) (iffail ...)

> data1.mas5 <- mas5(data1)
background correction: mas
PM/MM correction : mas
expression values: mas
background correcting...Error in mget(genenames, pos, envir, iffail =
NA) :
        unused argument(s) (iffail ...)
Execution halted

Bioconductor mailing list
Bioconductor at stat.math.ethz.ch 

More information about the Bioconductor mailing list